1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can not send e-mails using webmail

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by NickitasK, Jan 13, 2011.

  1. NickitasK

    NickitasK Guest

    0
     
    Dear all ,

    We had setup a Plesk 10.0.1 control panel , running on a CentOS 5.5 64bit . We are facing a problem with webmail (horde) . When trying to send an e-mail from webmail , nothing is sent (horde claims that message was sent successfully).
    We are using qmail as mailer-daemon . Here are some tests I 've made :

    1) Tailing /usr/local/psa/var/log/maillog (and grep through using the recipient's address gives nothing) .
    2) /var/log/psa-horde/psa-horde.log gives no useful info on this subject , only some login errors ...
    3) I tried using tcpdump on lo (I believe horde connects to loopback to send mail) but nothing appears .
    4) Manually connecting to lo using telnet and sending mail (worked ok)
    5) I saw another post on this forum , mentioning something about changing the symbolic link of sendmail binary . Although in our case sendmail bin links to /etc/alternatives/mta which also links to /var/qmail/bin/sendmail (i believe that's correct) , I tried the solution described there without any luck ...

    We have also applied some firewall rules that only permit root , qmail and mailman user to connect to port 25 for outbound traffic . These rules do not apply on lo though (tested using telnet and a local user) .

    I am running out of ideas so please in case someone figures out something that could be causing this problem feel free to share it :)

    Thank you in advance ...
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Try to remove and install back webmail with /usr/local/psa/admin/bin/webmailmng utility at least. --help option for details.
     
  3. NickitasK

    NickitasK Guest

    0
     
    Hi ,

    We have done the following without any luck ..

    /usr/local/psa/admin/bin/webmailmng --remove --name=horde
    /usr/local/psa/admin/bin/webmailmng --install --name=horde
    /usr/local/psa/admin/bin/websrvmng -v -a

    Is there something else we could try ?

    Thanx
     
  4. lhwparis

    lhwparis Guest

    0
     
    i am not shure but is hode using qmail or sendmail (via php) to send mails? try to allow sendmail
     
  5. NickitasK

    NickitasK Guest

    0
     
    Horde should be using the sendmail binary . As mentioned above the sendmail binary is linked to qmail's sendmail binary ..
     
Loading...