• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Cannot change net.ipv4.tcp_keepalive_time

JacobR9

New Pleskian
Hi,

I have Parallels Plesk Panel version 10.4.4 (centos-5-x86_64) and I would like to change the value of tcp_keepalive_time.
I tried to edit the sysctl.conf file using root:
Code:
sudo vi /etc/sysctl.conf
then added
Code:
net.ipv4.tcp_keepalive_time = 1800
then executed
Code:
sysctl -p

but I got the following error message:
Code:
error: permission denied on key 'net.ipv4.tcp_keepalive_time'

I also tried the following command with the same error message
Code:
 sudo sysctl -w net.ipv4.tcp_keepalive_time=1800

Any help?

Thanks
 
How it is related to Plesk?
Is it VPS or real server? Do you have SELinux enabled?
 
I wasn't sure if Plesk has some restrictions on sysctl.conf or not.
This is VPS, and SELinux is disabled.
 
You can't use sysctl options inside VPS because you haven't access to kernel from VPS. You should do it directly on hardware node.
 
Back
Top