1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Can't delete any domains

Discussion in 'Plesk for Windows - 8.x and Older' started by mikelegg, Oct 8, 2005.

  1. mikelegg

    mikelegg Guest

    0
     
    Can't create or delete any domains

    I can't delete any domains via Plesk, I have to manually delete them from IIS and remove all the records from the psa database.

    The latest in a long line of various errors that Plesk gives me is ...

    Unable to remove domains: Problems occurred while removing domains: unable to turn the domain off: domainmng failed: execute domainmng failed: remove "domain name" failed:Run time error can't query [then a big sql select statement ] MySQL error 1: cant create/write to file c:\c:\windows\temp\#sql_1d8_0.MYI (Errcode22)

    The c:\c:\ in the path is not a typo - thats where Plesk says it's trying to write - no wonder it hasn't got permissions!

    ------------------------------------------------------------------------
    I can't create new domains now either (Same error) - well at least that will limit my deleting problem!
    ------------------------------------------------------------------------
     
  2. mikelegg

    mikelegg Guest

    0
     
    So there are 2 possible problems:

    1. Plesk has a crazy path statement (c:\c:\) that needs to be fixed.

    Does anyone know where to change this?

    2. Plesk needs write permissions on the c:\windows\temp folder.

    Does anyone which Plesk user the database runs as?
     
  3. vekna

    vekna Guest

    0
     
    1. I can recommend create dump 'psa' database and search 'c:\c:\' string in it

    2. Give permission to psaadm and psaserv to temp folder - it should help you
     
  4. mikelegg

    mikelegg Guest

    0
     
    Problem Solved
    We added "tmpdir=C:\\temp\\" to C:\Program Files\SWsoft\Plesk\MySQL\Data\my.ini and created c:\temp with "everybody" read/write permissions.
     
  5. JAFO@

    JAFO@ Guest

    0
     
    Wow! I had that problem too, this solution helped! thanks a lot!
     
Loading...