1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

CBM 10.2.0-1 Whis Responses

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by maddieboi, Jun 17, 2011.

  1. maddieboi

    maddieboi Guest

    CBM 10.2.0-1 Whois Responses

    Hi All,

    I am going through the process of setting up my CBM install fully so I can have it do all my work for me...

    However, I am a little stuck when it comes to adding the Whois Server result info...

    in Australia, we can query the whois server at the Registry (server: whois-check.ausregistry.net.au). You send the domain name you are querying availablity for and it will return one of two results :

    Not Available

    Once it returns the result, is terminates the connection.

    How would I configure this in CBM to correctly check if a domain is available? If I set the "Whois Response" to Available, then ALL domains (both available and Not available) are returned...
    Last edited by a moderator: Jun 17, 2011
  2. EugeneL

    EugeneL Regular Pleskian

    Feb 18, 2011
    Likes Received:
    Hi, maddieboi

    I've checked service whois-check.ausregistry.net.au through CBM and it has returned either some info about taken domain or a string "No Data Found".

    In any case you can control whois check using two parameters in TLD profile (System configuration > Domain TLDs list > certain TLD). Set response fragment in "Whois response fragment" parameter and type IN or NOT IN in "Whois match rule" parameter. The second parameter controls if whois response MUST contain specified fragment to indicate domain as available or it MUST NOT contain specified fragment.

    For me these settings were set to:
    Whois response fragment = No Data Found
    Whois match rule = NOT IN