1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Chroot doesnt work?

Discussion in 'Plesk for Linux - 8.x and Older' started by Sempiterna, May 4, 2008.

  1. Sempiterna

    Sempiterna New Pleskian

    22
    73%
    Joined:
    Jul 24, 2005
    Messages:
    13
    Likes Received:
    0
    Hi,

    I was setting up Jailkit on my server to safely assign shell accounts (without domains) to users. However, eventho the users are restricted to their shell inside ssh, when they use ProFTPD to upload files, they can traverse the whole structure of the server.

    I have googled around a lot, and found that inside the /etc/proftpd.conf file i need to set "RequireValidShell off", but that does (even after a reboot, because plesk doesnt have proftpd as a service :/) not seem to do anything. That setting should work, but somehow with plesk inside the system, it does not.

    I have no idea what to do next. The chrooted environment works perfectly inside ssh, but if it doesnt work with FTP, then that defeats the whole purpose of a chrooted environment.

    Anyone have any idea as to how to do this?
     
  2. Monica@

    Monica@ Guest

    0
     
    Hi
    Plesk do use ProFTPd, however it runs not as a standalone server, but through xinetd/inetd. Anyway, if you take a look at the file /etc/xinetd.d/ftp_psa you will see that the configuration file used is /etc/proftpd.conf. This file has "Include" directive (see at the end):
    # cat /etc/proftpd.conf | grep ^Include
    Include /etc/proftpd.include
    Write your directive to this file and restart xinetd to apply the changes, it should work.
     
Loading...