1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ClamAV 0.88.2 not updating?

Discussion in 'Plesk for Windows - 8.x and Older' started by jerry2, Apr 17, 2006.

  1. jerry2

    jerry2 Guest

    0
     
    Hi there

    I use Plesk 7.5.6 and Clamav. Seems to be working fine, virus do get blocked (at least the fake files I got hands on)... But there are some problems...

    1. The clamd.exe seems to be not starting when rebooted. I have to start it by hand running start-clamd.bat. How can I make this permanent?

    2. My freshclam works in updating the virus definistions, but it doesn't work when scheduled from Plesk :-( Also I get this email to my admin email:

    Running task: C:\clamav-devel\bin\freshclam.exe
    Started: Tue Apr 18 00:00:00 2006
    The task output is attached to the e-mail
    Ended with code 62: Tue Apr 18 00:00:01 2006

    ERROR: Problem with internal logger.
    ERROR: Can't open /cygdrive/c/clamav-devel/log/freshclam.log in append mode (check permissions!).

    Anbody can help me please?
     
  2. Skeeter

    Skeeter Guest

    0
     
    Hello, Sir

    To have the antivirus starting at boot, you need to make sure it is selected in Plesk -> Server -> Components Management as the default Antivirus. You can also check if Clam AV service is set to run automatically (services should be checked during a terminal session).

    As for the update, make sure, that the file mentioned c/clamav-devel/log/freshclam.log
    has write permissions for the user, that executes the scheduled task. NTFS permissios can also be checked via remote Desktop.
     
  3. jerry2

    jerry2 Guest

    0
     
    I have found out that I have to give the log file Plesk administrator permission and it works.

    I didn't find how to set it up to run automatically though :-( It is set as default mail in Plesk, but I can not find it in services on my Windows 2003.
     
Loading...