• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Question Custom Mime Type for a specific file php.ini

Peter Downes

Basic Pleskian
Hi Forum

I have a .php file that outputs some javascript. When loaded with strict MIME type checking is enabled the browser reports an error:
"Refused to execute script from 'my.php' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled."

I have been trying for hours to resolve this problem. I've tried setting the content type in the file and in the .htaccess file.

Plesk may be my last hope.

In Plesk I can set up a custom MIME type for php.ini.
Does anybody know if I can set the MIME type for a single file instead of an extension?

Or any other ideas welcome.

Thanks
 
Back
Top