• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

DNS Slave configuration Problem

isomonkpiss

Basic Pleskian
Hello,

i hope someone can help me..

i m trying to configure a webmin vps as a slave zone for a secondary nameserver, master is plesk (12.5)

i followed this guide: nameservers are pointing: ns1 to plesk server and ns2 to webmin vps

https://talk.plesk.com/threads/guide-on-setting-up-master-secondary-dns-servers.288500/

i added the webmin vps ip to the Transfer Restrictions Template, changed ns2 IP in DNS Records of Domain targeting to webmin vps, firewalls are disabled but i get the following error in dnscheck

Name server ns2.domain.com (xxx.xxx.xxx.xxx) not authoritative for domain.com

and

At least one name server failed to respond in a timely manner
Failure detail: xxx.xxx.xxx.xxx

what can i do
 
Hi @isomonkpiss

Do you have a NS record for each nameserver in the zone for domain.com? If not, that could be why you are getting the "not authoritative" error when running a DNS check.

What happens if you run this command from the command line (replacing domain.com for the actual domain name):

Code:
dig domain.com @ns2.domain.com

Do you get a reply or a failure?
 
hello chris.. thank you for your help now i get a replay. it looks fine. my mistake was that i added ns2.domain.con as as slave dns in webmin and not domain.com

now i have another Prob.

when i press on Test Zone Transfer i get

Testing transfer of slave zone from MASTERIP ..
.. from MASTERIP : Completed OK

Test transfer successfully fetched 20 records from at least one nameserver. Actual transfers by BIND should also succeed

BUT

the slave Zone File still empty

This page shows the DNS records file /var/lib/bind/domain.com.hosts, created by BIND when the zone was transferred from the master server.

However the file is currently empty, probably because the zone has not yet been transferred from the master server

is something else i have to configure on slave? here is a screenshot

slave.png
 
Back
Top