• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

DNS Template . SRV

Frank.P

Regular Pleskian
TITLE:
DNS Template . SRV​
PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE:
Onyx 17.8​
PROBLEM DESCRIPTION:
Not allow use <ip> in SRV

img1.png​
STEPS TO REPRODUCE:
Try to create SRV Template with <ip> in host​
ACTUAL RESULT:
Not allow​
EXPECTED RESULT:
Allow save​
ANY ADDITIONAL INFORMATION:
​
YOUR EXPECTATIONS FROM PLESK SERVICE TEAM:
Confirm bug​
 
Hi Javier P.,

Could you please clarify why you expect that Plesk should allow saving IP-address as a target host for SRV-record? I have read rfc2782 and it looks like a "target" should not be an IP-address, only a domain name of the target host.

Code:
[...]
   Here is the format of the SRV RR, whose DNS type code is 33:

        _Service._Proto.Name TTL Class SRV Priority Weight Port Target
[...]
Target
        The domain name of the target host.  There MUST be one or more
        address records for this name, the name MUST NOT be an alias (in
        the sense of RFC 1034 or RFC 2181).  Implementors are urged, but
        not required, to return the address record(s) in the Additional
        Data section.  Unless and until permitted by future standards
        action, name compression is not to be used for this field.

        A Target of "." means that the service is decidedly not
        available at this domain.
[...]
(c) RFC 2782 - A DNS RR for specifying the location of services (DNS SRV)

In this case, I suggest creating an A-record for required IP-address and use its hostname as a target host in SRV-record.
 
Back
Top