1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Does Plesk 11 has PHP 5.4 Support?

Discussion in 'Plesk Suggestions and Feedback' started by Evilmachine, Jun 23, 2012.

  1. Evilmachine

    Evilmachine Basic Pleskian

    24
    23%
    Joined:
    Jan 8, 2008
    Messages:
    55
    Likes Received:
    0
    Hi there.

    Just wanted to know if Plesk 11 has PHP 5.4 Support.

    We plan to Upgrade from PHP 5.3.14 to PHP 5.4 because of some requests from our Customers.

    Didnt find anything in the Changelog.


    Hopfe you can help me.

    Regards from Germany

    Sascha urbansky
     
    Last edited: Jun 23, 2012
  2. Blake@Parallels

    Blake@Parallels Regular Pleskian

    24
    73%
    Joined:
    Jul 28, 2008
    Messages:
    168
    Likes Received:
    0
    Location:
    Seattle, WA
  3. Evilmachine

    Evilmachine Basic Pleskian

    24
    23%
    Joined:
    Jan 8, 2008
    Messages:
    55
    Likes Received:
    0
    Hmm Ok.

    When can we expect PHP 5.4 Support in Plesk??

    Webspaces with PHP 5.4 Support are rarely and for some customers a reason to buy.
     
  4. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Evilmachine, Plesk doesn’t ship client’s PHP, it only downloads it from original OS vendor repo and it is quite likely it may be outdated there. If you can upgrade your OS PHP with PHP 5.4, then Plesk would run PHP 5.4 for your clients.
     
  5. Evilmachine

    Evilmachine Basic Pleskian

    24
    23%
    Joined:
    Jan 8, 2008
    Messages:
    55
    Likes Received:
    0
    @abdi Thanks but i know. Thats the actual reason for my question.

    If i upgrade my PHP to the 5.4 branch does Plesk 11 recognize it and changes the options??

    Like deactive the safe_mode option because safe_mode is gone in PHP 5.4.

    I think i will try it on a test machine with a plesk 11 demo.
     
  6. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    I think plesk would recognize it. I havent tested this but logically, plesk plays with configuration files which regardless of the version of php, they are the same files ..so I think it might modify them accordingly and they get effected.
     
  7. EgidijusS

    EgidijusS Regular Pleskian

    23
    23%
    Joined:
    Jan 22, 2010
    Messages:
    183
    Likes Received:
    0
    Location:
    Vilnius, Lithuania
  8. motionpotion

    motionpotion Guest

    0
     
    @Evilmachine I am wondering the same as you as I need to upgrade PHP to 5.4.3 for an application to be supported.
    Did you test it out on the demo version of Plesk 11 yet?

    Perhaps the parallels support staff can get back onto this thread as they surely can explain what happens if PHP 5.4 is installed on Plesk 11?
     
  9. Evilmachine

    Evilmachine Basic Pleskian

    24
    23%
    Joined:
    Jan 8, 2008
    Messages:
    55
    Likes Received:
    0
    No i did not checked it yet.

    Had no time. Had someone else checked it yet??

    According to the Plesk Facebook Site PHP5.4 is not supported.
     
  10. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
  11. vikasbook

    vikasbook Guest

    0
     
  12. RaphaelN

    RaphaelN New Pleskian

    10
     
    Joined:
    Feb 13, 2013
    Messages:
    2
    Likes Received:
    0
    Hey.
    How can I update from PHP 5.2.17 to 5.3.21?
     
  13. Faris Raouf

    Faris Raouf Silver Pleskian Plesk Guru

    31
    30%
    Joined:
    Mar 15, 2009
    Messages:
    667
    Likes Received:
    17
    It depends on your OS. I'm guessing you are on Centos. But this is a thread about 5.4. Please can you start a new thread in the "Problems, Suggested fixes and How-tos" section of the forum? Be sure to state what OS you have, and what you have already tried etc etc.
     
Loading...