1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Domain alias www prefix doesn't work

Discussion in 'Plesk for Windows - 8.x and Older' started by Natalia Dewiyani, Mar 19, 2009.

  1. Natalia Dewiyani

    Natalia Dewiyani Guest

    0
     
    Hi there,

    I wonder if anyone can help me out here.

    For some reason all the domain alias won't work if www prefix is used. For example if I type in domain.com, it will work find and if I type www.domain.com it will go to 404 page - DNS error.

    I have tried to reconfigure svcmgr. I have also double check on IP address and make sure that www.domain.com and domain.com is listed.

    I have also deleted the domain alias and recreated it. Same problem.

    How do you work around it ? Where does domain alias controlled in IIS so I can work on it manually instead of going through plesk.

    Thanks
     
  2. runnetworks

    runnetworks Guest

    0
     
    run the following command on the domain:
    domain.exe -u domain.com -www true

    You may need to delete the domain alias and recreate it to fix the www prefix on the alias.

    We need to find out how to schedule this for all domains somehow, or parallels needs to fix the problem.
     
  3. Natalia Dewiyani

    Natalia Dewiyani Guest

    0
     
    I tried what you suggested but it doesn't work - it comes up with invalid command ? Could you provide step by step guide as I am not that familiar with plesk

    domain.exe -u domain.com -www true
     
  4. prince

    prince Regular Pleskian

    24
    53%
    Joined:
    Aug 16, 2006
    Messages:
    166
    Likes Received:
    0
    you can add hostheader for domain alias under the main domain's properties in IIS
     
  5. runnetworks

    runnetworks Guest

    0
     
    Sorry to reply to this old thread, but that's still a manual process. Is there any way to automate it?
     
Loading...