1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

DrWeb not starting?? Mail failed, sendmail error 111

Discussion in 'Plesk for Linux - 8.x and Older' started by SupportDesk, Dec 19, 2008.

  1. SupportDesk

    SupportDesk Guest

    0
     
    Hi,

    We have an issue with Plesk 8.6. Last we updated from 8.1 to 8.6 following this path:
    8.1.0 -> 8.2.0 -> 8.3.0 -> 8.4.0 -> 8.6.0.
    Now we have a problem with DrWeb.

    First when we try to activate it, Plesk spits out:
    "0: /usr/local/psa/admin/plib/drwebmng.php:31
    drwebmng::call_drwebmng_(string 'enable-check', array)
    1: /usr/local/psa/admin/plib/drwebmng.php:55
    drwebmng::enable_check(string '<a_domainname>', string 'info', NULL null, boolean true)
    2: /usr/local/psa/admin/plib/drwebmng.php:146
    drwebmng::applyStatus(array, array, string '')
    3: /usr/local/psa/admin/plib/registry/VirusFilter/drweb.php:123
    DrWebVirusFilterUserController->applyStatus(string '')
    4: /usr/local/psa/admin/plib/interfaces/VirusFilter.php:181
    VirusFilterManager::setActive(string 'drweb')
    5: /usr/local/psa/admin/htdocs/server/mail.php3:71

    But sending/receiving mail immediately stops and the maillog shows messages like:
    qmail-queue[12139]: users: wrong line(63)
    qmail-queue[12040]: users: error load users list from filename /etc/drweb/users.conf

    Line 63 of /etc/drweb/users.conf contains:
    allow --no-restart-service regex ^info@<a_domainname>$

    It's the same domainname which is mentioned by plesk in the error message.
    As soon as I comment this line, mail starts flowing again without any errors.

    I tried google, Parallels KB / Forum, but I can't find any messages/posts/sites with the same problem or I missed something.

    So I hope someone has an idea on what's happening here.
    If you need more info, please let me know.

    Thanks!
    Onno.
     
  2. gorilych

    gorilych Guest

    0
     
    This line:
    allow --no-restart-service regex ^info@<a_domainname>$

    has incorrect format for users.conf file. Just delete it.
     
  3. realaaa@

    realaaa@ Basic Pleskian

    23
    70%
    Joined:
    Mar 16, 2006
    Messages:
    67
    Likes Received:
    0
    I had the same problem, in my case the reply from qmail during attempts to send mail was:

    And the same errors in the maillog:

    It can be easily fixed by removing the invalid line, but - I'm not sure what caused this invalid line to appear in users.conf in the first place
     
Loading...