1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Email not checking

Discussion in 'Plesk for Linux - 8.x and Older' started by zboyblue, Aug 10, 2005.

  1. zboyblue

    zboyblue Guest

    0
     
    This is driving me CRAZY!!!!

    I have Plesk 7.5 Reloaded and inthe past I had Plesk 6 .. in both cases I have had this problem ..

    In outlook I have about 12 different accounts.... 99% of the time at least 2 of the accounts fail to check. It is not always the same account and there are no messages in webmail that are not clearing out. The message is always "The connection to the server was interrupted..." Sometimes restarting Outlook or the computer seems to help but not always, may be a coincidence.

    PLEASE PLEASE someone help me figure out what is going on, I can't take this anymore!

    Craig
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Have you tried increasing the Outlook Account Advanced settings to increase the default timeout value from 1 minute to a higher value?

    I have seen newer versions of NAV and McAfee email scanners and spam scanners cause larger than normal delays, resulting in timeouts (yes, even though you tell Norton to protect against timeouts).

    In 99.9% of the cases I have dealt with, increasing the value to 2 or 3 minutes gets rid of the problem.
     
  3. zboyblue

    zboyblue Guest

    0
     
    I think I tried that in the past and it didnt work. Can you tell me what I should check in NAV to see if it is causing the problems? Also, how can the timeout being 2 minutes make a diference? I mean it only takes seconds to check the mail ... so I think maybe I dont understand what the timeout is all about ...

    Could you explain? : )

    Craig
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I don't fully understand what Outlook is doing with their timeout either, I know it does not take that long to check emails, but for whatever reason, I have seen it make a difference, no rhyme or reason.

    With the newer 2005 versions of NAV and NIS, NSW I have seen this problem occur with much more frequency. The other test option would be to set Norton to not scan incoming emails and disable the additional 'Threats' categories. JUST AS A TEST to see if that makes a difference for your clients, it did for each of my clients who has experienced this problem, hence why I ended up setting Outlook's timeout higher.
     
  5. zboyblue

    zboyblue Guest

    0
     
    I tried all that and still no dice. Any other ideas?
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Have you used webmail to check if there is a SPAM mail with &nbsp or other malformed items which may be gumming up the email retrieval? This is also an old problem.

    And if you or the client are using Outlook 2003, then definitely download the latest updates for it. I have seen many other posts on other forums where 2003 users are having lots of connection problems...
     
  7. zboyblue

    zboyblue Guest

    0
     
    Yea, I checked that and that was not a problem. I checked all the accounts that I use and none of them had any messages like that.

    I am using Outlook XP (so the one before 2003)

    Any other ideas?
     
  8. mgalloway

    mgalloway Guest

    0
     
    I ran into this before, but I can't remember how to fix it. There is a variable that controls the maximum number of connects from the same IP, so it will only affect those with more than X email addresses that check e-mail simultaneously from the same IP.

    Does anyone know what parameter controls this?
     
  9. zboyblue

    zboyblue Guest

    0
     
    OOH! That sounds like the problem right there!! If someone knows where to increase the limit that would be awesome!

    Craig
     
  10. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Are you referring to the MAXPERIP option for IMAP? (not qmail related)

    Or did you patch your qmailsmtpd with the rate limit patch?

    Or had you played with your /etc/tcp.smtp file?

    Or were you thinking of the /var/qmail/control/concurrencylocal and concurrencyremote files?

    Any of this jog your memory??
     
  11. zboyblue

    zboyblue Guest

    0
     
    I am not sure about any of this, which ones could cause this problem?

    I just need to have qmail allow email checking of several email accounts from one IP at one time.

    Please let me know if you know what to do to fix this problem.

    Thanks so much

    Craig
     
  12. zboyblue

    zboyblue Guest

    0
     
    Ok someone at 4PSA told me this was a setting. Does anyone know which setting and where it is located?

    I would super duper appreciate it if someone knows and can tell me!

    Thanks!

    Craig
     
  13. mgalloway

    mgalloway Guest

    0
     
    Ok, here you go:

    Change the MAXPERIP=4 parameter in the following file:
    /usr/lib/courier-imap/etc/pop3 and/or imapd

    /You should probably also increase the number of pop3 servers.
    MAXDAEMONS=40

    Hope this helps...

    Good luck!
     
  14. zboyblue

    zboyblue Guest

    0
     
    WOW THANKS!!! I didnt change that setting because the following one seemed more appropriate:

    MAXPERIP=4

    I changed it to 10 and everything works great now!!!

    WOW, THANKS!!!!!

    Craig
     
  15. zboyblue

    zboyblue Guest

    0
     
    Strange .... the setting that I said earlier did do the trick and worked great. BUT for some reason a few days ago it stopped working. I looked at the file again and it was set back to 4! ??

    How would this happen?

    -zboyblue
     
  16. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
    I was researching a somewhat similar problem. The specifics of the problem was that every now and again our POP3 server became incredibly slow. At this point we noticed many connections by running this command:

    root@cm:~# netstat -an|grep :110 |awk '/tcp/ {print $6}'|sort|uniq -c
    33 CLOSE_WAIT
    2 CLOSING
    134 ESTABLISHED
    1 FIN_WAIT1
    2 LAST_ACK
    1 LISTEN
    13 SYN_RECV
    19 TIME_WAIT

    Notice 134 x Port 110 connections.

    At this point when we TELNETed to the local server on port 110 we could see the problem, very slow response before you get the banner. In many cases our clients actually phoned to say they are having timeouts. We knew it wasn't the server because we had just recently upgraded the hardware.

    We established Plesk uses Courier IMAP and POP3 daemon so that allowed us to do a more generic search of this problem. We also established when POP3 is slow IMAP is flying. First we were put off by this article which indicates due to strict compliance with RFCs Courier's POP3 daemon suffers from performance problems:
    http://www.unwin.org/postfix/slow-pop3d.html

    Luckily we also stumbled upon this article:
    http://kb.mediatemple.net/questions/259/(dv)+HOWTO:+Raise+Courier-IMAP+Connections

    We believe in our case the exact same is happening for POP3 connections as many of our clients come from a single IP and they have Microsoft Small Business Server with POP3 checking enabled.

    We increased the limits as per the article, MAXDAEMONS was 40 and is 80 now, and MAXPERIP was 4 and is 40 now, and the problem seems to have disappeared. Parallels should really up the default limits on Plesk to avoid other people having the same problem.
     
Loading...