1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

error 503, service not available

Discussion in 'Plesk 11.x for Linux' started by ZieglerM, Jun 24, 2012.

  1. ZieglerM

    ZieglerM Basic Pleskian

    14
    35%
    Joined:
    Jun 13, 2011
    Messages:
    41
    Likes Received:
    0
    hi all,

    almost every morning when logging into plesk panel i get the error message "error 503, service not available". after doing a "service psa restart" everything works again as it should.

    anyone else who is getting this error?

    thanks, martin
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    That means your plesk crashes such oftenly.

    Do you have anything in plesk logs that can give us a clue to what happens or leads it to crash?
     
  3. ZieglerM

    ZieglerM Basic Pleskian

    14
    35%
    Joined:
    Jun 13, 2011
    Messages:
    41
    Likes Received:
    0
    the only thing i can find is in /var/log/sw-cp-server/error_log:


    DEBUGGER DETECTED... Bye!
    2012-06-24 22:08:35: (mod_fastcgi.c.2613) unexpected end-of-file (perhaps the fastcgi process died): pid: 13042 socket: unix:/opt/psa/tmp/sw-engine.sock-0
    2012-06-24 22:08:35: (mod_fastcgi.c.3357) child signaled: 9
    2012-06-24 22:08:35: (mod_fastcgi.c.3400) response not received, request sent: 661 on socket: unix:/opt/psa/tmp/sw-engine.sock-0 for /login_up.php3?login_name=admin&passwd=0362092, closing connection
    2012-06-25 07:47:29: (server.c.1543) server stopped by UID = 0 PID = 3593
    2012-06-25 07:47:29: (log.c.166) server started
    2012-06-25 07:47:56: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe
    2012-06-25 07:59:39: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe
    2012-06-25 08:13:03: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe
    2012-06-25 08:58:00: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe
    2012-06-25 09:55:21: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe


    are there any other interesting logfiles beside of /opt/psa/admin/logs and /opt/psa/var/log?
     
    Last edited: Jun 25, 2012
  4. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Just out of curiosity, what are your server specs?
    Ie, RAM, CPU & SWAP ...

    From that error looks like mod_fastcgi too so long to respond to plesk which can be some times as a result of the server running out or memory (RAM) or SWAP.
     
  5. ZieglerM

    ZieglerM Basic Pleskian

    14
    35%
    Joined:
    Jun 13, 2011
    Messages:
    41
    Likes Received:
    0
    root@mail3:/var/log# free
    total used free shared buffers cached
    Mem: 8145804 7830152 315652 0 248840 5614096
    -/+ buffers/cache: 1967216 6178588
    Swap: 7999480 104664 7894816
    root@mail3:/var/log#



    root@mail3:/var/log# cat /proc/cpuinfo
    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 16
    model : 4
    model name : Quad-Core AMD Opteron(tm) Processor 1389
    stepping : 2
    microcode : 0x1000086
    cpu MHz : 800.000
    cache size : 512 KB
    physical id : 0
    siblings : 4
    core id : 0
    cpu cores : 4
    apicid : 0
    initial apicid : 0
    fpu : yes
    fpu_exception : yes
    cpuid level : 5
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt npt lbrv svm_lock nrip_save
    bogomips : 5800.24
    TLB size : 1024 4K pages
    clflush size : 64
    cache_alignment : 64
    address sizes : 48 bits physical, 48 bits virtual
    power management: ts ttp tm stc 100mhzsteps hwpstate
    [...]


    root@mail3:/var/log# uname -a
    Linux mail3.<domain> 3.2.0-25-generic #40-Ubuntu SMP Wed May 23 20:30:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    root@mail3:/var/log#



    root@mail3:/var/log# cat /etc/issue
    Ubuntu 12.04 LTS \n \l

    root@mail3:/var/log#



    do you need anything else? it is the latest revision of a standard server of one of the largest hosting providers here in Germany.
     
  6. paulieG

    paulieG Regular Pleskian

    25
     
    Joined:
    Mar 5, 2009
    Messages:
    164
    Likes Received:
    0
    Location:
    Lancaster
    Hi,

    Just to clarify, do you login then get the error, or does the error occur when you navigate to the Plesk panel? (The former I think used to be caused by lack of memory for the panel APC instance but that seems somewhat unlikely in your case since we used to see it on 256MB VPSs not 8GB dedicated servers).

    Is it the same rough time each day (22:08) that you have those errors in the log (and I assume that isn't your password)?

    I'm only running Plesk 11 on various Centos 5 and 6 VPSs, but I'm not having a problem with the Control Panel crashing.

    Paul.
     
  7. ZieglerM

    ZieglerM Basic Pleskian

    14
    35%
    Joined:
    Jun 13, 2011
    Messages:
    41
    Likes Received:
    0
    i get the error when accessing plesk panel via web.

    error_log:2012-06-24 07:27:44: (mod_fastcgi.c.3357) child signaled: 9
    error_log:2012-06-24 22:08:35: (mod_fastcgi.c.3357) child signaled: 9
    error_log.1:2012-06-17 13:18:49: (mod_fastcgi.c.3357) child signaled: 9
    error_log.1:2012-06-17 22:29:50: (mod_fastcgi.c.3357) child signaled: 9
    error_log.1:2012-06-20 19:54:46: (mod_fastcgi.c.3357) child signaled: 9
    error_log.1:2012-06-21 03:24:27: (mod_fastcgi.c.3357) child signaled: 9
    error_log.1:2012-06-23 03:06:06: (mod_fastcgi.c.3357) child signaled: 9
    error_log.1:2012-06-23 03:10:22: (mod_fastcgi.c.3357) child signaled: 9

    btw: i think i just found the reason why i'm not able to view logs via plesk panel although it looks like php was compiled with zlib:

    error_log.1:2012-06-20 10:33:05: (mod_fastcgi.c.2746) FastCGI-stderr: PHP Fatal error: Call to undefined function gzopen() in /opt/psa/admin/
    htdocs/domains/logs/log_file_viewer.php on line 59
    error_log.1:2012-06-20 10:33:11: (mod_fastcgi.c.2746) FastCGI-stderr: PHP Fatal error: Call to undefined function gzopen() in /opt/psa/admin/
    htdocs/domains/logs/log_file_viewer.php on line 59
    error_log.1:2012-06-20 10:33:16: (mod_fastcgi.c.2746) FastCGI-stderr: PHP Fatal error: Call to undefined function gzopen() in /opt/psa/admin/
    htdocs/domains/logs/log_file_viewer.php on line 59
    error_log.1:2012-06-20 10:33:22: (mod_fastcgi.c.2746) FastCGI-stderr: PHP Fatal error: Call to undefined function gzopen() in /opt/psa/admin/
    htdocs/domains/logs/log_file_viewer.php on line 59
    error_log.1:2012-06-20 10:34:13: (mod_fastcgi.c.2746) FastCGI-stderr: PHP Fatal error: Call to undefined function gzopen() in /opt/psa/admin/
    htdocs/domains/logs/log_file_viewer.php on line 59
    error_log.1:2012-06-20 10:34:16: (mod_fastcgi.c.2746) FastCGI-stderr: PHP Fatal error: Call to undefined function gzopen() in /opt/psa/admin/htdocs/domains/logs/log_file_viewer.php on line 59
     
  8. paulieG

    paulieG Regular Pleskian

    25
     
    Joined:
    Mar 5, 2009
    Messages:
    164
    Likes Received:
    0
    Location:
    Lancaster
  9. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
  10. ZieglerM

    ZieglerM Basic Pleskian

    14
    35%
    Joined:
    Jun 13, 2011
    Messages:
    41
    Likes Received:
    0
    i don't think that this is the cause of the problem, because until now i only added a few "small" customers to the server and the server load is quite low. anyhow, to give it a try i increased the values. let's see what happens.
     
  11. ZieglerM

    ZieglerM Basic Pleskian

    14
    35%
    Joined:
    Jun 13, 2011
    Messages:
    41
    Likes Received:
    0
    again got the error this morning:

    "503 - Service Not Available"

    # cat /var/log/error_log
    2012-07-01 20:43:48: (mod_fastcgi.c.2613) unexpected end-of-file (perhaps the fastcgi process died): pid: 4333 socket: unix:/opt/psa/tmp/sw-engine-8880.sock-0
    2012-07-01 20:43:48: (mod_fastcgi.c.3357) child signaled: 9
    2012-07-01 20:43:48: (mod_fastcgi.c.3400) response not received, request sent: 654 on socket: unix:/opt/psa/tmp/sw-engine-8880.sock-0 for /login_up.php3?login_name=admin&passwd=07081990, closing connection
    2012-07-01 23:19:11: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe
    DEBUGGER DETECTED... Bye!
    2012-07-04 01:25:02: (mod_fastcgi.c.2613) unexpected end-of-file (perhaps the fastcgi process died): pid: 28404 socket: unix:/opt/psa/tmp/sw-engine.sock-0
    2012-07-04 01:25:02: (mod_fastcgi.c.3357) child signaled: 9
    2012-07-04 01:25:02: (mod_fastcgi.c.3400) response not received, request sent: 659 on socket: unix:/opt/psa/tmp/sw-engine.sock-0 for /login_up.php3?login_name=admin&passwd=alois, closing connection
     
  12. ZieglerM

    ZieglerM Basic Pleskian

    14
    35%
    Joined:
    Jun 13, 2011
    Messages:
    41
    Likes Received:
    0
    today it happened again.

    any ideas please?
     
  13. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    I can't say what is wrong there. Detailed investigation directly on your server is required. Therefore I suggest you contact Support Team. Experienced support guys will find a reason...

    However, you can also try this:

    Usually If hosting more than 300 Web sites on the server, Apache may fail to work because of problem with file descriptors limit. Apache by default can handle only 1024 file descriptors. Every Virtual Host requires 2 or 4 (if HTTPS is enabled) log files, so with this scheme only about 300 domains can be hosted without Apache recompilation.

    Piped Logs feature that was implemented in Plesk allows to host safely on the default Apache web server build up to 900 domains. If you have more that 900 domains, you still have to recompile Apache and some other system packages as described in article (http://kb.parallels.com/en/260). To enable Piped Logs the following steps have to be done:

    As a root user:

    Code:
     mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e "replace into misc (param,val) values ('apache_pipelog', 'true');" 
    and
    Code:
    /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
     
  14. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Also, you can try to increasing the $ulimit value.

    First you need to verify if ulimit is set. Try executing the command:

    Code:
    echo $ulimit
    If it is blank or a low value, try executing the command:

    Code:
    ulimit -n 131072
    In order to make this change permanent

    Code:
    vim /etc/sysctl.conf
    and add following lines

    Code:
    fs.file-max = 131072
    /sbin/sysctl -w fs.file-max=131072
    
    Then

    Code:
    mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e "replace into misc (param,val) values ('apache_pipelog', 'true');" 
    then,

    /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
    /etc/init.d/httpd restart
     
  15. WernerD

    WernerD Guest

    0
     
    same error #503 sw-cp-server

    I'm usung PLESK 11 on UBUNTU 12.04 LTS and get error in /var/log/sw-cp-server/error_log:

    DEBUGGER DETECTED... Bye!
    2012-08-21 20:51:25: (mod_fastcgi.c.2613) unexpected end-of-file (perhaps the fastcgi process died): pid: 24305 socket: unix:/opt/psa/tmp/sw-engine.sock-0.
    2012-08-21 20:51:25: (mod_fastcgi.c.3357) child signaled: 9.
    2012-08-21 20:51:25: (mod_fastcgi.c.3400) response not received, request sent: 656 on socket: unix:/opt/psa/tmp/sw-engine.sock-0 for /login_up.php3?login_name=admin&passwd=carlo, closing connection.
    2012-08-21 20:51:38: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe.
    2012-08-21 20:56:40: (server.c.1543) server stopped by UID = 0 PID = 24418.

    I get error #503, after restarting sw-cp.server it works again for about 12 to 24 hours

    Any Idea / solution ?
     
  16. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Looks like upgrade was not successfully completed. Try bootstrapper repair.
     
  17. WernerD

    WernerD Guest

    0
     
    bootstrapper repair was succesfully .... but same errors after about 10 hours ...

    2012-08-23 04:55:14: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe.
    DEBUGGER DETECTED... Bye!
    2012-08-23 05:00:17: (mod_fastcgi.c.2613) unexpected end-of-file (perhaps the fastcgi process died): pid: 15059 socket: unix:/opt/psa/tmp/sw-engine.sock-0.
    2012-08-23 05:00:17: (mod_fastcgi.c.3357) child signaled: 9.
    2012-08-23 05:00:17: (mod_fastcgi.c.3400) response not received, request sent: 497 on socket: unix:/opt/psa/tmp/sw-engine.sock-0 for /index.php?, closing connection.
    2012-08-23 05:00:17: (server.c.1543) server stopped by UID = 0 PID = 15123.
    2012-08-23 05:00:18: (log.c.166) server started.
    2012-08-23 05:05:20: (connections.c.1762) SSL (error): 5 -1 32 Broken pipe
     
  18. Knarf

    Knarf Basic Pleskian

    18
    85%
    Joined:
    Jan 22, 2011
    Messages:
    60
    Likes Received:
    0
    Location:
    The Netherlands
    Today I had the same error message "error 503, service not available" at the Plesk login page.
    The server is a freshly installed server (7 days ago) with Ubuntu 12.04 and Plesk 11.0.9 update #19.

    This is in the /var/log/sw-cp-server/error_log:

    I also wonder what the line is with login_name=admin&passwd=meier because it is not mine, is someone trying to hack the server?

    I restarted the whole server to get Plesk working again because the psa service restart didn't work.
     
  19. LegionFX

    LegionFX Basic Pleskian

    14
     
    Joined:
    Nov 8, 2011
    Messages:
    26
    Likes Received:
    0
    same problem here, fresh server installed, error 503 only in panel not domains once a day and REALLY high cpu load! Jesus really high, 260 - 500 % the only solution is restart and it can hold for a few hours. 1 domain only installed(im a test junkie), 8 g ram, quad core. this is only after the last update.

    the same thing happens in another server it diferent specs and configuration. Meaning its plesk problem in the last update.
     
  20. Thomas Papamichail

    Thomas Papamichail New Pleskian

    19
    80%
    Joined:
    Apr 16, 2010
    Messages:
    4
    Likes Received:
    0
    Don't forget to check your hdd. Maybe the disk is full
    # df -h
     
Loading...