1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ERROR: PleskFatalException (please urgent help)

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by AyazA, Aug 3, 2010.

  1. AyazA

    AyazA Guest

    0
     
    hi...

    i am godaddy virtual dedicate server customer.

    yesterday i was update my server file via SSh by that command :

    wget -q -O - http://www.atomicorp.com/installers/atomic |sh

    and then just run:

    yum update


    after that all installation and updating was complete and the complete word was showed on the SSH screen.
    after completing i reboot the server but my plesk panel is not going to open and give me mysql database error.

    ERROR: PleskFatalException
    Unable to connect to database: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    0: common_func.php3:146
    psaerror(string 'Unable to connect to database: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)')
    1: auth.php3:93



    please how to fix it and solve that issue.

    please any help me urgent.


    Thanks in ADVNS
    Best Regards
    Admin of NSW
    Ayaz Ali
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
  3. AyazA

    AyazA Guest

    0
     
    thanks for great helping....
    mysql working start successfully.


    but when try to repair all my database by maintion a command in above link but give me error :

    [root@ip-97-74-193-222 /]# mysqlcheck --check-upgrade --all-databases --auto-repair -u admin -pyouradminpassword
    mysqlcheck: Got error: 1045: Access denied for user 'admin'@'localhost' (using password: YES) when trying to connect


    and also when i restart my server service by that command :

    /sbin/service httpd restart

    which give me one warn :

    [root@ip-97-74-193-222 /]# /sbin/service httpd restart
    Stopping httpd: [ OK ]
    Starting httpd: [Wed Aug 04 13:35:34 2010] [warn] module ssl_module is already loaded, skipping
    [ OK ]



    please help on that issue too.

    Thanks in ADVNS
    Best Regards
    Admin of NSW
    Ayaz Ali
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Make sure that you have equal admin password in /etc/psa/.psa.shadow and in mysql table.
     
  5. AyazA

    AyazA Guest

    0
     
    sir i done it which password is stored in /etc/psa/.psa.shadow but still same error.

    and also when i restart my server service by that command :

    /sbin/service httpd restart

    which give me one warn :

    [root@ip-97-74-193-222 /]# /sbin/service httpd restart
    Stopping httpd: [ OK ]
    Starting httpd: [Wed Aug 04 13:35:34 2010] [warn] module ssl_module is already loaded, skipping
    [ OK ]



    please help on that issue too.

    Thanks in ADVNS
    Best Regards
    Admin of NSW
    Ayaz Ali
     
  6. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
  7. AyazA

    AyazA Guest

    0
     
    thank you so much and my problem solved.

    now i have one other problem. when i open phpMyAdmin which is show me wronging message in footer phpMyAdmin.

    error message :
    Your PHP MySQL library version 5.0.90 differs from your MySQL server version 5.1.48. This may cause unpredictable behavior.


    Apache v2.2.3
    phpMyAdmin - 2.11.9.6
    Server version: 5.1.48
    MySQL client version: 5.0.90
    PHP 5.2.14

    how i can fix it.


    Thanks in ADVNS
    Best Regards
    Admin of NSW
    Ayaz Ali
     
  8. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    It looks like that there is incorrect version of php mysql module loaded from /etc/php.d/mysql.ini
    Check it.
     
  9. AyazA

    AyazA Guest

    0
     
    sir i check that file but there i found that :


    ; Enable mysql extension module
    extension=mysql.so


    what i add in above file ?
    how i can fix it


    Thanks in ADVNS
    Best Regards
    Admin of NSW
    Ayaz Ali
     
  10. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Maybe this warning occurred because of php and php-mysql installed from ART repository instead of official ones. You can find it with 'art' part of packages name. The problem here is php-mysql-x.x.x-art is compiled to use libraries from MySQL 4. To get rid off this message you should either compile own php-mysql module using both PHP and MySQL libs version 5, or to move to official shipment (php and mysql4 for CentOS).

    Generally this warning may be safely ignored, as MySQL is backwards compatible and instructions for 5 will work in 4. The same way module compiled for 4 will work for 5.

    Note that it is only my assumptions. If you need more detailed investigation - contact Parallels support team.
     
Loading...