1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

error sending outgoing emails when smtp authentication is turned on

Discussion in 'Plesk for Linux - 8.x and Older' started by profe, Jun 29, 2005.

  1. profe

    profe Guest

    0
     
    I suspect that whatever process that verifies passwords for smtp connections is different or performs it differently than the process that verifies passwords for pop3.

    For example:

    220 domain.com ESMTP
    EHLO mycomputername
    250-domain.com
    250-AUTH=LOGIN CRAM-MD5 PLAIN
    250-AUTH LOGIN CRAM-MD5 PLAIN
    250-STARTTLS
    250-PIPELINING
    250 8BITMIME
    AUTH LOGIN
    334 VXNlcm5hbWU6
    (encoded "username@domain.com")
    334 UGFzc3dvcmQ6
    (encoded "123456")
    535 auth failure

    Does not work, while:

    +OK Hello there.
    USER username@domain.com
    +OK Password required.
    PASS 123456
    +OK logged in.
    QUIT
    +OK Bye-bye.

    Works fine.

    Excluding an open relay, of course, the only way I can figure out how to enable outgoing messages is to configure in Plesk Server->Mail to authenticate via POP3 and then set the outlook settings to login to the incoming server before sending outgoing messages. It should be able to authenticate via smtp, but it doesn't.

    Why does smtp authentication not work at all? Is this a known issue or is it just me?
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Normally the Plesk server would be set for SMTP auth, no relay, no POP3 auth.

    Outlook you would login using 'user@domain.com', not just 'user' and make sure you put a checkmark in 'My server requires authentication', but NO checkmark for 'Logon using Secure Password Authentication'.

    And have Outlook set for 'Use same settings as my incoming mail server'

    Also do NOT put checkmarks in either:
    'This server requires a secure connection (SSL)' for incoming and outgoing server settings.

    This has worked for countless thousands of clients, through many versions of plesk.

    Using the 'user@domain.com' as the login name will work whether you have the server set for short names or short/full names option.
     
  3. profe

    profe Guest

    0
     
    I realize what the correct settings should be for Plesk and Outlook. This is why I provided the real tcp/ip communications; to show you that for some reason my installation of Plesk is not working the way it was intended. The smtp process is not able to validate users, while the pop3 process is able.

    Also, the horde database in mysql is completely empty. The tables exist, but no records are ever created no matter how many email users I create in Plesk. Webmail does not work as a result. I wonder if the problems are related. It is possible that what may be going on is a faulty Plesk installation.

    How would I go about reinstalling Plesk without losing all of my settings, domains, and users?
     
  4. joinindia

    joinindia Basic Pleskian

    23
     
    Joined:
    Jan 18, 2003
    Messages:
    36
    Likes Received:
    0
    How to Activate Secure SSL SMTP Relay

    Hello,

    Can any one tell me the way so that I can activate Secure connection using SSL port 465 in my Plesk 7 box.

    so that every mail which goes should go only with secure SSL connection and not open?

    Thanks!
     
  5. profe

    profe Guest

    0
     
    It was, in fact, a faulty installation of Plesk. I reformatted / reinstalled and everything works as intended. The real solution may have been more elegant, but considering all of the problems I was having starting over was a sound option. My server is now the best it has ever been.

    I have determined the root cause of my fault installation. When running the autoinstaller script in the beginning, it failed when installing the VPN module. This was because my operating system did not have the necessary packages on which the VPN module depended. Since the VPN module came before the Webmail module in the autoinstaller script, the script never completely installed Plesk. During the recent reinstall phase, I skipped the VPN module (selecting everything else) and Plesk installed flawlessly.
     
Loading...