1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ERROR: Unable to install the "plesk-core-10.9.0-cos5.build109101029.17.i386" package.

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by br14nw, Jan 11, 2011.

  1. br14nw

    br14nw Guest

    0
     
    I'm getting the following error when trying to use the autoinstaller on a fresh CentOS 5.5 32bit installation.

    Retrieving information about the installed packages...
    File downloading BILLING_7.0.1/update-rpm-RedHat-all-all/update-7.0.1-rhall-all.hdr.gz: 100% was finished.
    File downloading BILLING_7.0.1/dist-rpm-RedHat-all-all/build-7.0.1-rhall-all.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading SITEBUILDER_5.0.0/dist-rpm-RedHat-all-all/build-5.0.0-rhall-all.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading BILLING_7.0.1/thirdparty-rpm-RedHat-all-all/thirdparty-7.0.1-rhall-all.hdr.gz: 100% was finished.
    File downloading SITEBUILDER_5.0.0/thirdparty-rpm-RedHat-all-all/thirdparty-5.0.0-rhall-all.hdr.gz: 100% was finished.
    File downloading PSA_10.0.1/dist-rpm-CentOS-5-i386/build-10.0.1-cos5-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading PSA_10.0.1/update-rpm-CentOS-5-i386/update-10.0.1-cos5-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% was finished.
    File downloading PSA_10.0.1/thirdparty-rpm-CentOS-5-i386/thirdparty-10.0.1-cos5-i386.hdr.gz: 12%..22%..32%..40%..52%..62%..71%..81%..91%..100% was finished.
    File downloading SITEBUILDER_5.0.0/update-rpm-RedHat-all-all/update-5.0.0-rhall-all.hdr.gz: 100% was finished.
    Determining the packages that need to be installed.
    ERROR: Unable to install the "plesk-core-10.9.0-cos5.build109101029.17.i386" package.
    Not all packages were installed.
    Please, contact product technical support.

    I'm unable to find logs with any other information. Any suggestions?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Try to find a reason in /tmp/autoinstaller3.log autoinstaller log file.
     
  3. br14nw

    br14nw Guest

    0
     
    The logs show a problem with the bind.

    Find directly required packages for bind-30:9.3.6-4.P1.el5_4.2.i386
    - there is another package 'bind-libs-30:9.3.6-4.P1.el5_5.3.i386' with same name in necessaryList
    Migrating bind-libs-30:9.3.6-4.P1.el5_4.2.i386 to blacklist
    Add package bind-30:9.3.6-4.P1.el5_4.2.i386 to black list because its dependency 'bind-libs = 30:9.3.6-4.P1.el5_4.2' resolved only by black-listed package bind-libs-30:9.3.6-4.P1.el5_4.2.i386.
    Add package bind-devel-30:9.3.6-4.P1.el5_4.2.i386 to black list because its dependency 'bind-libs = 30:9.3.6-4.P1.el5_4.2' resolved only by black-listed package bind-libs-30:9.3.6-4.P1.el5_4.2.i386.
    Add package bind-libbind-devel-30:9.3.6-4.P1.el5_4.2.i386 to black list because its dependency 'bind-libs = 30:9.3.6-4.P1.el5_4.2' resolved only by black-listed package bind-libs-30:9.3.6-4.P1.el5_4.2.i386.
    Add package bind-utils-30:9.3.6-4.P1.el5_4.2.i386 to black list because its dependency 'bind-libs = 30:9.3.6-4.P1.el5_4.2' resolved only by black-listed package bind-libs-30:9.3.6-4.P1.el5_4.2.i386.
    Migrating bind-30:9.3.6-4.P1.el5_4.2.i386 to blacklist
    Add package plesk-core-10.9.0-cos5.build109101029.17.i386 to black list because its dependency 'bind >= 9.2.1' resolved only by black-listed package bind-30:9.3.6-4.P1.el5_4.2.i386.
    Add package bind-chroot-30:9.3.6-4.P1.el5_4.2.i386 to black list because its dependency 'bind = 30:9.3.6-4.P1.el5_4.2' resolved only by black-listed package bind-30:9.3.6-4.P1.el5_4.2.i386.
    Add package bind-sdb-30:9.3.6-4.P1.el5_4.2.i386 to black list because its dependency 'bind = 30:9.3.6-4.P1.el5_4.2' resolved only by black-listed package bind-30:9.3.6-4.P1.el5_4.2.i386.
    Add package caching-nameserver-30:9.3.6-4.P1.el5_4.2.i386 to black list because its dependency 'bind = 30:9.3.6-4.P1.el5_4.2' resolved only by black-listed package bind-30:9.3.6-4.P1.el5_4.2.i386.
    Migrating plesk-core-10.9.0-cos5.build109101029.17.i386 to blacklist
    The requested package "plesk-core" could not be installed.
    Searching problems for the "plesk-core" package.
    No suitable solutions were found for the "bind >= 9.2.1" dependency.
    The "bind-30:9.3.6-4.P1.el5_4.2.i386" package resolves "bind >= 9.2.1".
    Could not add package bind-libs-30:9.3.6-4.P1.el5_4.2.i386to the list of required packages.Problem occured during searching directly resolved dependencies for 'bind-libs = 30:9.3.6-4.P1.el5_4.2' of package bind-30:9.3.6-4.P1.el5_4.2.i386 -- Check for new version of PSA_10.0.1/plesk-10.0.1-cos5-i386.inf3
    Filefetcher: get file (~empty)/PSA_10.0.1/plesk-10.0.1-cos5-i386.inf3
    -- Check for new version of SITEBUILDER_5.0.0/sitebuilder-5.0.0-rhall-all.inf3
    Filefetcher: get file (~empty)/SITEBUILDER_5.0.0/sitebuilder-5.0.0-rhall-all.inf3
    -- Check for new version of BILLING_7.0.1/billing-7.0.1-rhall-all.inf3
    Filefetcher: get file (~empty)/BILLING_7.0.1/billing-7.0.1-rhall-all.inf3
    Execute command /usr/sbin/getenforce
    Disabled
    Error: Unable to install the "plesk-core-10.9.0-cos5.build109101029.17.i386" package.
    Not all packages were installed.
    Please, contact product technical support.

    I'm guessing it wants bind 9.2.1?
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
    Try to remove all bind related packages before Plesk installation.
     
  5. br14nw

    br14nw Guest

    0
     
    EDIT: I found bind-libs and bind-utils on the system. I've removed those and the installer appears to be working now. I'll update if I have anymore issues.

    Thanks for the assist.
     
    Last edited by a moderator: Jan 13, 2011
  6. br14nw

    br14nw Guest

    0
     
    The install worked perfectly after that and the control panel is up and running.

    Thanks again for the help.
     
Loading...