• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Error updating to 12.5.30

Jamie_Davies

New Pleskian
Hello,

I'm running CentOS release 5.11 (Final) on a VPS and have just tired to update to 12.5.30 through the web interface. I got the following error. This has now broken the plesk admin page and I'm having to go through SSH to try to update.

When running the auto installer from SSH the following fatal error is given:

Code:
Running rpm_check_debug

Fatal error during packages installation: Test Transaction Errors:   package libarchive-2.8.4-14042917.x86_64 (which is newer than libarchive-2.8.4-6.el5.i386) is already installed

YumTestTransactionError: Test Transaction Errors:   package libarchive-2.8.4-14042917.x86_64 (which is newer than libarchive-2.8.4-6.el5.i386) is already installed

ERROR: Failed to run the Yum utility.

The Yum utility failed to install the required packages.

Attention! Your software might be inoperable.

Please, contact product technical support.

Any advice would be gratefully received. I have been googling for the last hour and haven't found anything of use. I did find one post on here, but it did not have any impact on my issue.

All the best,

Jamie
 
Hi Jamie_Davies,

please have a look at this post:
I was able to install libarchive using yum (epel repo was already installed), but this didn't create the missing library. At the moment of your post I had someone from Odin support on my server and couldn't mess with it anymore.
They did this to solve it:

Code:
# ldd /usr/bin/sw-engine | grep -i libarchive.so.2
libarchive.so.2 => not found
# rpm -Uvh libarchive-2.8.4-14042917.x86_64.rpm --force
# ldd /usr/bin/sw-engine | grep -i libarchive.so.2
libarchive.so.2 => /usr/lib64/libarchive.so.2 (0x00002afc12bd2000)
#

Source: https://talk.plesk.com/threads/upgrade-to-12-5-failed.334970/
 
Hi Jamie_Davies,

consider to provide ALL informations, so that suggestions and investigations are not useless. If you did some manual commands over your command line, please do tell us, WHAT you did, WHICH commands you were using and WHAT the output over the command line looked like.

In addition, please note that Plesk 12.5 comes with a bunch of repair utilities, which help to solve issues.


Please consider as well to provide log - entries from installation/update/upgrade/repair logs, to help you to investigate your issue. The specific log and its path is always mentioned, when using autoinstaller, bootstrapper or repair - utilities.
 
Back
Top