• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Error when accessing backup via reverse proxy

TobiasP

Regular Pleskian
When accessing a backup in backup-manager in a user subscription via a reverse proxy (eg. plesk panel is called as localhost:8443) I get following error:

Internal error: Failed to exec pmm-ras: (array ( 'code' => 127, 'stdout' => 'Transport error: File \'clients\' not found ', 'stderr' => '', )).
Message Failed to exec pmm-ras: (array ( 'code' => 127, 'stdout' => 'Transport error: File \'clients\' not found ', 'stderr' => '', )).
File Connector.php
Line 227
Type PleskPMMResponseException

this happens when I try to download the backup and also when clicking on the backup name.
These are the apache settings for the reverseproxy domain:

SSLProxyEngine On
AllowEncodedSlashes On
<Location />
ProxyPass https://localhost:8443/
ProxyPassReverse https://localhost:8443/
</Location>
 
Back
Top