• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Error when open Database list

daniiii_e

Basic Pleskian
Hi,

i get a error when i open the Database list.
gf3rew4q.png


-->
https://localhost:8443/smb/database/list


ERROR: Call to a member function getApplicationContext() on null (Databases.php:105)

Search for related Knowledge Base articles

Thanks,
Daniel
 
[2015-10-01 13:58:57] ERR [1] Unable to connect to database: mysql_connect(): No such file or directory (Error code: 2002)
[01-Oct-2015 14:00:02 Europe/Berlin] PHP Fatal error: Call to a member function getApplicationContext() on null in /opt/psa/admin/plib/Smb/View/List/Databases.php on line 105
[2015-10-01 14:01:34] ERR [panel] Unable to connect to database: mysql_connect(): No such file or directory (Error code: 2002):
0: /opt/psa/admin/plib/CommonPanel/Application/Abstract.php:69
CommonPanel_Application_Abstract::initDbAdapter()
1: /opt/psa/admin/plib/Session/Helper.php:150
Plesk\Session\Helper::initStorage()
2: /opt/psa/admin/plib/auth.php:325
AutoPrepend->initUserSession()
3: /opt/psa/admin/plib/auth.php:230
AutoPrepend->run()
4: /opt/psa/admin/plib/auth.php:759
[2015-10-01 14:01:34] ERR [1] Unable to connect to database: mysql_connect(): No such file or directory (Error code: 2002)
[2015-10-01 14:01:43] ERR [panel] Unable to connect to database: mysql_connect(): No such file or directory (Error code: 2002):
0: /opt/psa/admin/plib/CommonPanel/Application/Abstract.php:69
CommonPanel_Application_Abstract::initDbAdapter()
1: /opt/psa/admin/plib/Session/Helper.php:150
Plesk\Session\Helper::initStorage()
2: /opt/psa/admin/plib/auth.php:325
AutoPrepend->initUserSession()
3: /opt/psa/admin/plib/auth.php:230
AutoPrepend->run()
4: /opt/psa/admin/plib/auth.php:759
[2015-10-01 14:01:43] ERR [1] Unable to connect to database: mysql_connect(): No such file or directory (Error code: 2002)
[2015-10-01 14:13:46] ERR [panel] Can not find client 'danielehrhardt'
[2015-10-01 14:13:46] ERR [panel] Can not find client 'danielehrhardt'
[01-Oct-2015 14:19:13 Europe/Berlin] PHP Fatal error: Call to a member function getApplicationContext() on null in /opt/psa/admin/plib/Smb/View/List/Databases.php on line 105
[01-Oct-2015 14:19:34 Europe/Berlin] PHP Fatal error: Call to a member function getApplicationContext() on null in /opt/psa/admin/plib/Smb/View/List/Databases.php on line 105
[01-Oct-2015 14:28:06 Europe/Berlin] PHP Fatal error: Call to a member function getApplicationContext() on null in /opt/psa/admin/plib/Smb/View/List/Databases.php on line 105
[01-Oct-2015 14:28:28 Europe/Berlin] PHP Fatal error: Call to a member function getApplicationContext() on null in /opt/psa/admin/plib/Smb/View/List/Databases.php on line 105
[01-Oct-2015 14:33:46 Europe/Berlin] PHP Fatal error: Call to a member function getApplicationContext() on null in /opt/psa/admin/plib/Smb/View/List/Databases.php on line 105
[2015-10-01 14:54:36] ERR [panel] [Action Log] Failed login attempt with login 'root' from IP 89.204.130.215
[01-Oct-2015 15:01:00 Europe/Berlin] PHP Fatal error: Call to a member function getApplicationContext() on null in /opt/psa/admin/plib/Smb/View/List/Databases.php on line 105
[01-Oct-2015 15:01:08 Europe/Berlin] PHP Fatal error: Call to a member function getApplicationContext() on null in /opt/psa/admin/plib/Smb/View/List/Databases.php on line 105
 
Are you sure that mysql service is up and running? Have you tried restart it? Any errors?
 
i think it is since the Update from 12.0 to 12.5

now my version is v. 12.5.30

and i make a apt-get update && apt-get upgrade
 
Back
Top