• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Error when trying to run httpdmng

tkalfaoglu

Silver Pleskian
Hello. Due to an error in template configs, I'm tried running httpdmng, but it fails with:

/usr/local/psa/admin/bin/httpdmng --reconfigure-all
Unable to register configuration file: template=domainVhost, domain.id=185


I followed:
http://kb.parallels.com/en/112815
http://kb.parallels.com/en/11288
http://kb.parallels.com/en/112882

but none of them seems to exactly apply.. The first one seems to fit, but in step #2, the subscription.id displayed is not zero.. So I did not want to proceed.

(Even a "select" that would enable me to see the domain name with this ID would be helpful.. Maybe I can delete that domain and re-create it afterwards..)

Any ideas what I should do?
Thanks, -t
 
First of all find name of this domain with

mysql> select id,name from domains where id=185;

Usually this error occurs when domain is configured to non-existent IP address. Check it and reconfigure domain.
Also following article may be useful - http://kb.parallels.com/114632
 
Thanks!

That article you quoted is worth its weight in gold -- I was able to fix the psa database with no effort..
Many thanks!
-turgut
 
First of all find name of this domain with

mysql> select id,name from domains where id=185;

Usually this error occurs when domain is configured to non-existent IP address. Check it and reconfigure domain.
Also following article may be useful - http://kb.parallels.com/114632

I'm getting the same errors while trying to delete a domain, I can see it in the domains table, but how do I find out what IP address it's supposed to be using?
 
Back
Top