1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

error with upgrading to SB2 (packages already installed)

Discussion in 'Legacy Sitebuilder Software' started by warrior, Jun 7, 2005.

  1. warrior

    warrior Guest

    0
     
    You guys at the discussion "Sb 2.0!!" wanted to hear some issues before upgrading to SB2, I think I have one:

    - I read page 13 of the SB2 install guide
    - Then I remove config.php from /usr/local/sitebuilder/include
    - As I wanted to install the rpm's I got the following error:

    [root@server2 Sitebuilder]# rpm -Uhv *.rpm
    Preparing... ########################################### [100%]
    package expat-1.95.5-2 is already installed
    package js-1.5rc5a-1 is already installed
    package sablotron-1.0.1-2 is already installed
    package php-xslt-1.0-0 is already installed
    [root@server2 Sitebuilder]#

    After that, the command line appeared again.

    I had version 1.1.1 and never upgraded to any RC from version 2.

    Nor I never was prompted to enter any DNS settings.

    After some tries I had to copy the config.php back and it worked with version 1.1.1.

    I appreciate every suggestion,

    Miguel
     
  2. timtrott

    timtrott Guest

    0
     
    Plesk Support told me:

    Before the upgrade from SiteBuilder version 1.0 to version 2.0 it is necessary to make a back up copy of the folder /usr/local/sitebuilder and the database used by SiteBuilder.

    To install SiteBuilder correctly the following command must be used:
    rpm -Uhv Sitebuilder-2.0-xxxxxxxx.rpm

    In order for installation modules to work correctly, the following command must be used:
    rpm -Uhv sitebuilder-module_???_??????_xxxx.rpm
     
  3. warrior

    warrior Guest

    0
     
    Thanks timtrott, but it didn't worked out. Now I got following errors:

    After that I've tried to go to the admin and I got the following error when accepting the basic configurations:

    The log file has the following content:

    Is it just a permission error at user sb_user? If yes, how can I change this?

    Thanks,

    Miguel
     
  4. benjiprince

    benjiprince Guest

    0
     
    [root@server2 Sitebuilder]# rpm -Uhv *.rpm --force

    try --force as above, this worked 4 me
     
  5. warrior

    warrior Guest

    0
     
    Thanks, before I tried to force, how could I change permissions to the "sb_user" db user, so he can drop this database?
     
  6. benjiprince

    benjiprince Guest

    0
     
    i cant advise on this directly

    i upgraded from 2rc to new release 2 on a local testing server
    and because it was not detrimental to my work i dropped the 2rc database and let the new install populate the new 2 vers with the new tables etc on upgrade process ... then it accepted its own default name and pw and proceeded to admin panel.

    i am still working on the jump to upgrade 1.1.1 to 2.0.0 in a production server environment but as yet there are a few issues to resolve before taking the leap of faith

    I say, be careful during early stages and ask sw-swoft via ticket help department before taking serious alterations if your sitebuilder work is not to be gambled with ....

    good luck
     
  7. warrior

    warrior Guest

    0
     
    I've used your suggestion and the installation worked fine! However as the admin web interface appeared and I had to configure the db, I've received the following error:

    At the log file there is the same problem like yesterday, just the user permissions.
     
  8. benjiprince

    benjiprince Guest

    0
     
    try this...
    instead of using sb_user default names and password, use your plesk panel admin name and its password to proceed populating the db ....
     
  9. warrior

    warrior Guest

    0
     
    I went a little step forward. After getting the initial login screen, I put the plesk admin user and password and now I get the following error:

    If I put the former user name, it doesn't work (login incorrect screen).
     
  10. benjiprince

    benjiprince Guest

    0
     
  11. timtrott

    timtrott Guest

    0
     
    I have decided to pay Plesk to do the install. All things considered, it's the most cost-effective option.
     
  12. isplhost.net

    isplhost.net Guest

    0
     
    open put your server in command line (or use putty, if leased)

    then on the root
    # mysql -u user -p

    here, replace user with your root user's name, so it is basically,
    mysql -u root -p

    then you password is asked, type your root pass, it you should be able to access you db now, try to issue, # use sitebuilder; if it works, try to issue, # show tables;

    tables must be shown now.. if they do...

    which they will, on th eprevious install page.. change the db user to root and the root password, and use sitebuilder db.

    I hope this helps!
     
  13. CiViX

    CiViX Guest

    0
     
    The file /usr/local/sitebuilder/include/kernel/licensekey.php must be owned by apache:apache otherwise SB2 will not work. After the install the file seems to be owned by plesk:plesk which is wrong. Just change the owner and group, and everything will work fine.

    chown apache:apache /usr/local/sitebuilder/include/kernel/licensekey.php
     
  14. warrior

    warrior Guest

    0
     
    Thanks CiViX, but I'm still receiving the same error:

    The owner for the file licensekey.php is set ok to apache:apache.

    The wizard works perfect until step 5 (Publish), where the error appears.

    Also when trying to log into the administration, the same error occurs.
    Some advice?

    Miguel
     
  15. warrior

    warrior Guest

    0
     
    Finally I got Sitebuilder 2.0 working! It was a hotfix that was missing. I asked the company that sells me SB and they send me the hotfix. Now I'm trying to learn about the new features. It seems to be an exciting package.
     
  16. dunas

    dunas Guest

    0
     
    Hi Warrior

    I have the same problem with SB2, one cuestion:

    The hotfix, where is publised?

    thanks!
     
  17. warrior

    warrior Guest

    0
     
    As far as I know it's not published. Send me your email via PM and I'll send you the hotfix
     
  18. dunas

    dunas Guest

    0
     
    My email in PM, send. Thanks in advance!
     
Loading...