1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FastCGI in Plesk 11/CentOS 6.3 - Timeout issues

Discussion in 'Plesk 11.x for Linux' started by Gary.B, Dec 16, 2012.

  1. Gary.B

    Gary.B New Pleskian

    10
     
    Joined:
    Dec 16, 2012
    Messages:
    2
    Likes Received:
    0
    PHP support is currently set to: run as Fast CGI.

    I keep getting these errors in my server log:
    mod_fcgid: read data timeout in 45 seconds
    Premature end of script headers: index.php

    Should be quick fix I think, but I cant find the file to edit. Is this something I can change from Plesk.
    Anyone know how to increase the timeout?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  3. Gary.B

    Gary.B New Pleskian

    10
     
    Joined:
    Dec 16, 2012
    Messages:
    2
    Likes Received:
    0
    /etc/httpd/conf.d/fcgid.conf
    This file does not exist on my server

    I have three files inside etc folder: group, password and php.ini

    In Plesk, I went into Website & Domain > File Manager to create folder httpd, I get this:
    Error: Unable to create directory /etc/httpd: filemng: Error occurred during /bin/mkdir command.
     
    Last edited: Dec 17, 2012
  4. freaky@

    freaky@ Regular Pleskian

    26
     
    Joined:
    May 2, 2006
    Messages:
    104
    Likes Received:
    0
    FYI on Ubuntu (and probably possible other debian based distro's) the configuration is in /etc/apache2/mods-available/fcgid.conf

    I changed FcgidIOTimeout to 120 there. 45 seconds was too small for a few specific export scripts and some other, 120 seems fine here. Personally don't care much for the shotgun approach by setting it to 1 or 2 hours (besides - PHP execution time limit will kick in way before that) - 1 script running for 1 or 2 hours is not accepted here anyways. But whatever value that exceeds the time it needs to run should suffice. I'd add a bit for cases where the server might be busy with other stuff too.
     
Loading...