1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FCGIWrapper dynamic 9.3 update

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by IP-Burn3r, Jan 14, 2010.

  1. IP-Burn3r

    IP-Burn3r Guest

    0
     
    Had to manually change this in all vhosts include file to the following --> FCGIWrapper /usr/bin/php-cgi .php
    was FCGIWrapper dynamic .php


    Apache would not restart when FCGIWrapper dynamic .php was present.


    This error happened as soon as I updated to verison 9.3 from 9.2.3
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,556
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    The original issue occurs because CGI_PHP_BIN parameter specified not correct:

    that's why domain configs were generated incorrectly. For fixing that you have to fix it to /usr/bin/php-cgi

     
  3. IP-Burn3r

    IP-Burn3r Guest

    0
     
    If I run as FastCGI application all sites get a 500 internal error.

    Running /usr/local/psa/admin/sbin/websrvmng -a -v only makes the problem worse, it adds spaces in the CGI_PHP_BIN parameter, in return service httpd will not restart. Would have to go and manually change all site's conf/httpd.include to fix the problem.


    At this time Im running all sites as an apache module.

    Thanks for the help. ;)
     
  4. IP-Burn3r

    IP-Burn3r Guest

    0
     
    Anyone can help with this?
     
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,556
    Likes Received:
    1,241
    Location:
    Novosibirsk, Russia
    I haven't understood, whether my recommendation has helped?
     
  6. T Feigl

    T Feigl Guest

    0
     
    Same Problem

    Hi,
    i have the same problem. all domains stop working when using php with fastcgi on one single domainl. Apache goes down and can't be restarted. Need help!!!
    Greetings Feigl
     
Loading...