1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

File manager and FTP access problem after vhost location update

Discussion in 'Plesk for Linux - 8.x and Older' started by neodepo, Jun 1, 2008.

  1. neodepo

    neodepo Guest

    0
     
    Hello

    I had a very small partition at my server where /var/www/vhost/ was located
    so I moved my vihost to
    /home/www/vhost/

    I did this using the "transvhosts.pl" tool.
    It worked fine but it suddenly stopped when updating database.

    I am able to access all my domains using a browser but I can not acces through FTP (I am getting password fail error) and if I try to access via the Plesk Control panel I am getting the following error:

    ERROR: PleskFatalException
    Unable to resolve rath path to file /home/www/vhosts/neodepo.com

    0: /usr/local/psa/admin/plib/class.Checker.php:785
    Checker::filepath(string '/home/www/vhosts/neodepo.com', string '/home/www/vhosts/neodepo.com', string 'neodepo')
    1: /usr/local/psa/admin/plib/class.FileManager.php:528
    FileManager->get_file_path(string '/')
    2: /usr/local/psa/admin/plib/class.FileManager.php:699
    FileList->fetchFileList()
    3: /usr/local/psa/admin/plib/class.cList.php3:97
    cList->fetchList()
    4: /usr/local/psa/admin/plib/class.cList.php3:117
    cList->init()
    5: /usr/local/psa/admin/htdocs/filemanager/filemanager.php:621


    The path "/home/www/vhosts/neodepo.com" does exist
    The user home is ok (pointing to the new path) and I have also created a symbolic link just in case.

    If I create a new domain I do can access FTP and plesk control panel file manager

    What can I do?

    Thanks in advance!

    Neo
     
  2. neodepo

    neodepo Guest

    0
     
    Hello, I have already solved my problem.
    The home for the users was wrong, I updated home paths at the /etc/passwd file and everything worked just fine.
     
Loading...