1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FreeBSD 6.1 support

Discussion in 'Plesk for Linux - 8.x and Older' started by wettoast, May 26, 2006.

  1. wettoast

    wettoast Guest

    0
     
    Has anyone tried installing 8 on FreeBSD 6.1? If it's not supported yet, does anyone know when it will be? Plesk 8 promised to support new OS releases quicker, lets see if it will live up to that claim.
     
  2. joshuavautour

    joshuavautour Guest

    0
     
    It's a little difficult to test if it works on 6.1 they've added the 6.0 version to the installer. Anyone bothered to go as far as making and installer patch for me :)?

    Josh
     
  3. joshuavautour

    joshuavautour Guest

    0
     
    Well I did it..and it seems to work just fine. I would suggest decompressing the installer then modifying the Tar file.


    All in all the plesk 8 for BSD 6.0 works fine on BSD 6.1
     
  4. wettoast

    wettoast Guest

    0
     
    Modify how? Wouldnt that change the checksum of the file? It's not surprising it work fine btw, as the FreeBSD POLA guarantees no API change on minor releases. Plesk should target major releases, and not restric to specific minor ones.
     
  5. joshuavautour

    joshuavautour Guest

    0
     
    Here are the steps to get it installed.

    Unzip the archive downloaded from swsoft

    Modify the Tar file as I did below.

    Line # New Code (What I changed)
    -----------------------------------------------------------
    70934 conceived_os_version="6.1" (was "6.0")
    70935 osrels="fr6.1" (was "fr6.0")

    77312 5_3_5_3|5_4_5_4|6_1_6_1 (was 6_0_6_0)
    1454617 5_3_5_3|5_4_5_4|6_1_6_1 (was 6_0_6_0)


    Then UnTar everying and install

    Hope this helps
     
  6. Ophelus

    Ophelus Guest

    0
     
    I'm tottally lost.. you wouldn't post simple edit commands would you.. (because I'm not sure much about hex editing and or basic english editing I can do)

    If editing the tar it ends up looking like this..

    Ld\x9a\x9am^Q[SP0F\xd2@\xe6^B#\xe9\x92f\xa8\xdc@^Z\xb51VT\xaaa\x9bJ\x92\xc9$\xd3\xe2\x9a)\xdf\x84I\xf1%`\xbf\xdf\x9bd\xbb\xa0\xc0\xe3\x96j*\\xb5^U\x93\xda^V\
    x95 \x92eK\x82\xdf^TDU\xdd\xca\x85B\xb0\xdb\xfbh^FU,\x8c^Q\xc3^La\x85"\xc32\xa9\xaeh\xc4\xb0^Ml1*\xe5\x86HIs\x81`\xc8\x90\xa1.T\xdb\xe4X\xe1\x8aiI\x92E\x
    88E\x90mJX\xd6\xb4\xdc^P\xf0\xa0^K^F212^UMQ9\xa1*\xc1\xaa)\xab\xd4T(T\x86\x82^U\xc3\xc6^N^LO?\xb7\xa6\xe1\x94\xcb\xb6Lt\xd3\xa0\xaa&\xeb\xc4\xc4\x86%k634\xdd
    \x80V\xcf\x85\xc1<n\x95\xa1b]\x95^Q6\xb0n2x^M^E\xd9P\xc1^DQ^C\xd9^FR\xf4\xdc^H\xfd^Yq32\x89j26e^C\xde\xc2F^V\xc5\xb6\x8c\xb8\xc64\xdb\x94\x91B)\xcd\x85\xc1\x
    93\x92\xc1\x8e\xddZ\xd6\xc0\xb2\xaa`\xd5^BwgJ\x94J\x9a-\x99*\xd4'b^Fa\x8e\x96

    If editing the .sh file there is english reading scripts.. and I edited portions that ended with freebsd 6.0 and 6_0_6_0

    This actually got the installer rolling into it hit the checksum and then said file corrupt..

    ===> Checking integrity of package...
    Package file appears to be corrupted. Please download
    original file from download page.
    Do not attempt to install this archive file.
     
  7. joshuavautour

    joshuavautour Guest

    0
     
    Just Search it

    There is actually plain text in the tar file mixed in with the hex/binary stuff. Just do searches on the original values and you'll find them.

    Good Luck
     
  8. wettoast

    wettoast Guest

    0
     
    Since editing the distribution file in Plesk 7 resulted in a checksum failiure, what i did on the FreeBSD 5 is fake the version to satisfy Plesk. That is, i would build and install from the latest RELENG5 sources, but modify /usr/src/sys/conf/newvers.sh to display 5.3. This worked great, but still, better wait for official 6.1 support, but god knows how long that will take, probably when 6.2 is out :p
     
  9. Ophelus

    Ophelus Guest

    0
     
    Well really my problem is likely vi I guess.. since I can't use nano/pico to open (too big)

    And I get even get the go to line command to work so.. I dunno guess I'll work through it.. course if you could just provide a download to a modified .tar file works for me

    I don't really want to mess around with a custom build wettoast for 6.1.. it'd be easier to just step back and do 6.0 then do that..

    Be happy to provide a ftp if needed for the file ;)
     
  10. wettoast

    wettoast Guest

    0
     
    Try the ee editor.
     
  11. Ophelus

    Ophelus Guest

    0
     
    Tried it got a error..

    reading file "psa_v8.0.0_build80060406.16_os_FreeBSD_6.0_i386.sh.tar"Segmentation fault (core dumped)

    I'm just going to give up for the moment unless some one wants to post a easier method..
     
Loading...