• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

FTP server weird behavior

sebas

Basic Pleskian
Creating a directory work fine. But when uploading files using FTP the problem is that it cycles from the client perspective.

Once a file has been uploaded the client starts to upload it again and then ask if it should be overwritten and again and again.

It happens with the server not just one domain.

Here is a log of a session.

Command: MKD ftp-test
Response: 257 "/httpdocs/ftp-test" - Directory successfully created
Status: Retrieving directory listing...
Command: CWD ftp-test
Response: 250 CWD command successful
Command: PWD
Response: 257 "/httpdocs/ftp-test" is the current directory
Command: PASV
Response: 227 Entering Passive Mode (74,86,16,34,136,218).
Command: MLSD
Response: 150 Opening ASCII mode data connection for MLSD
Response: 226 Transfer complete
Status: Directory listing successful
Status: Resolving address of ftp.tolkien.com.mx
Status: Connecting to 74.86.16.34:21...
Status: Connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.4a Server (ProFTPD) [74.86.16.34]
Command: USER ttototo
Response: 331 Password required for ttototo
Command: PASS ******************
Response: 230 User ttototo logged in
Status: Connected
Status: Starting upload of E:\Users\Public\Documents\tmp\a.php
Command: CWD /httpdocs/ftp-test
Response: 250 CWD command successful
Command: PWD
Response: 257 "/httpdocs/ftp-test" is the current directory
Command: TYPE A
Response: 200 Type set to A
Command: PASV
Response: 227 Entering Passive Mode (74,86,16,34,229,38).
Command: STOR a.php
Response: 150 Opening ASCII mode data connection for a.php
Error: Connection timed out
Error: File transfer failed
Status: Resolving address of ftp.tolkien.com.mx
Status: Connecting to 74.86.16.34:21...
Status: Connection established, waiting for welcome message...
Response: 220 ProFTPD 1.3.4a Server (ProFTPD) [74.86.16.34]
Command: USER ttototo
Response: 331 Password required for ttototo
Command: PASS ******************
Response: 230 User ttototo logged in
Status: Connected
Status: Starting upload of E:\Users\Public\Documents\tmp\a.php
Command: CWD /httpdocs/ftp-test
Response: 250 CWD command successful
Status: Retrieving directory listing...
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (74,86,16,34,182,225).
Command: MLSD
Response: 150 Opening ASCII mode data connection for MLSD
Response: 226 Transfer complete
Status: Skipping upload of E:\Users\Public\Documents\tmp\a.php
Status: File transfer successful, transferred 355 bytes in 6 seconds

Thanks for your help.

_________________
Red Hat Enterprise Linux Server release 6.1 (Santiago)
Plesk psa-10.4.2-rhel6.build1013111020
 
Back
Top