1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ftp timestamps incorrect ?

Discussion in 'Plesk for Linux - 8.x and Older' started by drawkcaB, May 30, 2005.

  1. drawkcaB

    drawkcaB Guest

    0
     
    I have a freshly installed Plesk 7.5.3 installation on Debian. Timezones are set correctly to GMT+10 (Melbourne). The time is set. Synchronisation is set to a local server.

    The Plesk interface reports the correct time.
    If I 'touch' a file via ssh it leaves the correct timestamp. However, all files uploaded via ftp are incorrectly timestamped (10 hours out). As if proftpd doesnt seem to be obeying my timezone settings ?
    Anyone seen this silly qwerk before ?
     
  2. bartje3

    bartje3 Guest

    0
     
    You can easy set this value in your ftp client, check this first before you search for a solution on the server.

    Regards,
    Bart
     
  3. drawkcaB

    drawkcaB Guest

    0
     
    Timezones/Time settings are correct on the client PCs I have tested from. I do not encounter this problem when uploading to other ftp servers I have hosted elsewhere (also proftpd).
    Have tried from multiple PCs and ftp clients. Still get the 10 hour difference.
     
  4. bartje3

    bartje3 Guest

    0
     
    And what if you upload a file using the integrated filemanager in Plesk ?

    Same ?

    Bart
     
  5. drawkcaB

    drawkcaB Guest

    0
     
    This is the bizarre thing, it writes the correct file stamp to the file. (If I 'ls -l' the files they are correct to the filesystem). Its just that when LIST in any ftp client (or pc.. I have tested from 3 different machines) the files are 10 hours out.

    To confirm, the machines I have tested from all have their timezones set to GMT+10 and the correct time set. The server is set to GMT+10 and the correct time set.

    Ps. Even worst, I just realised it reports them as 2004.. ? weird:

    Internet Explorer FTP:
    test.html 1 KB 5/31/2004 11:01:00 PM

    ls -l from ssh:
    -rw-r--r-- 1 testsite psacln 8 Jun 1 09:01 test.html
     
  6. drawkcaB

    drawkcaB Guest

    0
     
    Turned out to be a proftpd thing after all.

    Can be tweaked by adding the below to /etc/proftpd.conf

    Code:
    # time setting
    TimesGMT off
    
    I can only assume that this config is overlooked for the debian install of plesk only, as Im sure many other Plesk users would have seen this before if it occured on the other nix* distrobutions.
     
  7. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    I have the same issue on Red Hat Enterprise 3 (ES) on 7.5.2
    It might be a recent problem. Mine are all off similar to you.

    hope this fixes me as well
     
Loading...