1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

hard disk quota not supported

Discussion in 'Plesk for Linux - 8.x and Older' started by rmatosplk, Nov 17, 2005.

  1. rmatosplk

    rmatosplk Guest

    0
     
    Hello, everyone.

    I am running Plesk at this version:

    7.5.4-debian3.1.build75050824.12

    When i´m adding a domain and if i choose one domain model, the panel gives me an error saying that it can´t apply that model because of the error below:

    Hard disk quota not supported.

    I still can complete the domain name creation, though.

    I tried to replace usermng file with the one located at
    http://www.yep-media.de/usermng/usermng but things got worse so i gave up.

    Quota support is enabled on the server and commands like repquota or edquota work fine. The problem seems to happen only within Plesk. Is there any patch for that?

    Any clues? Has anybody experienced the same?

    Thanks in advance.

    Best Regards,
    Ricardo Matos
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
  3. rmatosplk

    rmatosplk Guest

    0
     
    Thanks for your answer, ShadowMan...

    Although the post you´ve indicated shows the same problem on the same distribution than mine, i don´t use xfs filesystem, but reiserfs.

    As far as i could see, /etc/mtab looks good:

    /dev/md0 / reiserfs rw,noatime,nodiratime,notail,usrquota,grpquota 0 0
    proc /proc proc rw 0 0
    devpts /dev/pts devpts rw,gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs rw 0 0

    So, i´m still clueless on this issue.. :(

    Thanks in advance.

    Best Regards,
    Ricardo Matos
    Contact Center - Digiweb
    www.digiweb.com.br
     
  4. rmatosplk

    rmatosplk Guest

    0
     
    Hello, everyone.

    Just for your knowledge, i´ve solved the quota problem by using FreeBSD instead of Debian.

    I think there´s a incompatibility issue between Plesk and some operating systems.

    Ricardo Matos
    Contact Center - Digiweb
    www.digiweb.com.br
     
  5. madeddie

    madeddie Guest

    0
     
    I'll just put this here because people with my problem will probably find this specific topic:

    To make quota work on an installed Plesk Reloaded on Debian, I did the following:

    # apt-get install quota
    # modprobe quota_v2
    # touch /aquota.user /aquota.group
    # chmod 600 /aquota.*
    # mount -o remount /
    # quotacheck -avugm
    # quotaon -avug

    (obviously everything done as root)
    after this plesk stops complaining about quotas not being supported. You (and me) probably have to add quota_v2 to /etc/modules so it will load next boot.
    For clearity, I have an EXT3 filesystem on / and the fstab line already has the usrquota option.

    I have no idea if something has to change in the installer (perhaps the quota package needs to be installed), but this'll make it work if quota didn't work after install.

    --
    edwin
     
Loading...