1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

how to turn off php safe mode

Discussion in 'Plesk for Linux - 8.x and Older' started by starving_artist, Mar 22, 2006.

  1. starving_artist

    starving_artist Guest

    0
     
    Whats up,

    I am trying to set up a php module (photogallery) and I get the following message:

    'safe_mode' need to be Off. Please request your server administrator to modify the configurations for you. \

    How do I go about this?

    Thanks
     
  2. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    add vhost.conf at /var/www/vhosts/domain.com/conf/

    with the following lines:

    <Directory /var/www/vhosts/domain.com/httpdocs>
    php_admin_value safe_mode Off
    </Directory>

    then run

    /usr/local/psa/admin/bin/websrvmng --reconfigure-vhost --vhost-name=<domain_name>

    then run

    service httpd restart
     
  3. starving_artist

    starving_artist Guest

    0
     
    thanks but would you or any one else possibly be able to explain that in lamen (sp?) terms. I'm not sure what any of that means....
     
  4. ibor

    ibor Guest

    0
     
    hi,

    please tell me why putty comes with the following error if i try to make this :


    the error is like ... error with newline ...

    or sth.

    please tell me how to make this correct !

    - i couldnt find it anywhere !

    Thank you SWsoft !


    greetz ibor
     
  5. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    have you replaced <domain_name> with the real domain name?
     
  6. ibor

    ibor Guest

    0
     
    hi yes i have ... but the domain name contains chars like "." "-" etc. - is that the problem ?

    please give me answer ... im sitting here since yesterday only to find a way to get rid off safe_mode ... - its really important for me caus emy scripts wont run ...

    THX for your support !

    BTW: how to run it with putty - just the path - or do i have to make other commands ?
     
  7. ibor

    ibor Guest

    0
     
    hi,

    if theres no other opportunity ... i have a problem ... my problem is to get rid off safe_mode - i know how to change th php.ini - after apache restart - php safe_mode is displayed as off - but in configure commands its still on - so

    HOW To change the php configure command settings of plesk 7.5.4 reloaded with the ssh client putty --- it would be very very nice - if someone would give me any answer - please give answer !


    THX !!!!!!


    greetz ibor
     
  8. ibor

    ibor Guest

    0
     
    ok . i think i found the mistake ^^

    i thought i have to write :

    /usr/local/psa/admin/bin/websrvmng --reconfigure-vhost --vhost-name=<domain_name>

    and not :

    /usr/local/psa/admin/bin/websrvmng --reconfigure-vhost --vhost-name=domain_name


    - now my problem is solved - thx!

    greetz ibor
     
  9. starving_artist

    starving_artist Guest

    0
     
    Ok I think I understand most of this...but by problem not is that plesk won't let me make any changes to my conf file, it says permission denied...wtf

    how can i gain access to this file?
     
  10. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    you need to become root to edit these files. Login with SSH and type "su -" and enter the root password.
     
  11. ibor

    ibor Guest

    0
     
    hi,

    you get that error cause you try to run

    /var/www/vhosts/domain.com/conf/vhost.conf

    but thats wrong --- you have to edit and/or make new file ... just read the following :

    to edit a file u have to use an editor ... vi or pico ... so try the following with your ssh client :

    vi /var/www/vhosts/domain.com/conf/vhost.conf


    and then if you get a new screen ... with a look like an editor Oo - press i for insert and insert the stuff whats is here ... :

    <Directory /var/www/vhosts/domain.com/httpdocs>
    php_admin_value safe_mode Off
    </Directory>

    after it press "ESC" and after that ... press "!!" - (with putty ^^)

    and then there has to be a new line under the editor .. like this

    :

    here type "wq" - and then <enter> .

    now just call the other one :

    /usr/local/psa/admin/bin/websrvmng --reconfigure-vhost --vhost-name=domain_name

    without any prefix ... and then restart apache .. in plesk - thats easier than to make it with ssh ^^

    - greetz from ibor
    :cool:

    PS: if this helps you to disable safe_mode - just let me know - http://robert-beran.de/guestbook.php ;)
     
  12. starving_artist

    starving_artist Guest

    0
     
    after all the crazy things i have tried this actually worked. thanks for the help everybody

    i'll be back soon to harass everyone about my smtp problems
     
Loading...