1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

https SSL not working

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by AutoChris, Oct 27, 2010.

  1. AutoChris

    AutoChris Guest

    0
     
    Hi all, I've tried searching this forum and Google and emailing my host but I'm just getting nowhere.

    I've tried it with "SSL support" turned on and off and "Use a single directory for housing SSL and non-SSL content" but I'm just not getting any sense from what I see.

    http://domain.com works fine but https://domain.com just throws up a 404 no matter what I do. I've bought a certificate and tried to install it (seemed to accept it).

    I've gone through Domains > domain.com > SSL certificates AND Settings > SSL certificates but no joy.

    I've put a test document in the httpsdocs folder to see if it's because of something like that but it isn't. It just hangs and I get a 404 / "Internet Explorer cannot display the webpage".

    My understanding is that you don't need a certificate to get https to work but the browser will simply warn you?

    No idea how to do this. It's the only thing that's had me baffled.

    THANK YOU
     
  2. AutoChris

    AutoChris Guest

    0
     
    Hi all! $30 via PayPal for the post that inspires me to solve this. I haven't got a clue.

    I seem to have done everything.

    What should happen if I simply turn on SSL with "SSL support" but no certificate? Should I get something? What about with a certificate? I'm resetting the VSP server by going to Virtuozzo and clicking restart container.

    Thank you
     
  3. AutoChris

    AutoChris Guest

    0
     
    ARGH! It was my firewall. Thanks
     
Loading...