1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

I think i broke postfix by updating it.

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by DerrickH, Jun 2, 2011.

  1. DerrickH

    DerrickH Basic Pleskian

    17
    85%
    Joined:
    Sep 26, 2010
    Messages:
    33
    Likes Received:
    0
    So on the suggestion of a parrelells support rep, i tried to install an updated version of postfix.

    it failed citing some dependencies. fine, or so i thought, now i get:

    ERROR: mail_Exception_ManagerExecution

    Up Level
    mailmng failed: Fatal error: plesk::mail::postfix::postfixConfigurationError(/usr/sbin/postconf: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
    )

    0: Manager.php:186
    mail_Manager->callMailMngWithException(string 'get-max-letter-size')
    1: AbstractManager.php:349
    mail_AbstractManager->getMaxLetterSize()
    2: Manager.php:395
    mail_Manager->getMaxLetterSize()
    3: AbstractFacade.php:1173
    mail_AbstractFacade->getMaxLetterSize()
    4: mail.php3:219
    require(string '/opt/psa/admin/htdocs/server/mail.php3')
    5: plesk.php:58

    when i try and enter the mail server settings area in the panel.

    also for some reason apt-get install -f wants to uninstall a buttload of plesk:


    sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
    lib32bz2-1.0 pwgen libts-0.0-0 psa-awstats-configurator sw-librrd xsltproc
    sharutils log4cpp-plesk libdigest-sha1-perl libv4l-0 libnet-ip-perl
    sw-rrdtool libnet-dns-perl lib32ncurses5 psa-pear php5-xsl re2c
    ttf-dejavu-core ia32-libs libnet-xwhois-perl php5
    pp-sitebuilder-default-templates awstats libboost-program-options1.40.0
    php5-sqlite libgomp1 xinetd libsqlite0 libcairo2 libapache2-mod-php5 php5-gd
    libthai-data gcc-4.4 psa-spf2 psa-php5-configurator lib32gcc1
    libdirectfb-1.2-0 libdatrie1 fontconfig spamc lib32asound2
    libpango1.0-common psa-courier-imap libpixman-1-0 php5-curl libt1-5
    psa-mail-driver-common gcc psa-ftputil libxft2 fontconfig-config
    libapache2-mod-python libthai0 curl php5-ioncube-loader libxpm4
    psa-locale-base-en-us libxrender1 liberror-perl webalizer x-ttcidfont-conf
    libgd2-xpm php5-imap wwwconfig-common libsocket6-perl libc6-dev tsconf
    libdb4.7 libsysfs2 psa-logrotate libsasl2-modules-sqlite3 libfontconfig1
    lib32z1 libpango1.0-0 php5-mysql libnetaddr-ip-perl lib32stdc++6
    linux-libc-dev manpages-dev php5-cgi libmail-spf-perl libboost-regex1.40.0
    libxcb-render0 php5-cli lib32v4l-0 sqlite3 libc-dev-bin sw-collectd
    pp-sitebuilder-skins binutils psa-proftpd libsys-hostname-long-perl
    libxcb-render-util0 php5-common libdigest-hmac-perl python-libxml2
    spamassassin sw-doctrine libio-socket-inet6-perl
    Use 'apt-get autoremove' to remove them.
    The following packages will be REMOVED:
    bsd-mailx mailman plesk-core plesk-l10n plesk-mail-pc-driver postfix
    postfix-pcre pp-sitebuilder psa psa-atmail psa-backup-manager
    psa-drweb-configurator psa-fileserver psa-firewall psa-health-monitor
    psa-horde psa-imp psa-ingo psa-kronolith psa-mailman-configurator
    psa-migration-agents psa-migration-manager psa-mimp psa-miva psa-mnemo
    psa-passwd psa-spamassassin psa-turba psa-updates psa-vhost psa-watchdog
    sshterm
    0 upgraded, 0 newly installed, 32 to remove and 77 not upgraded.
    1 not fully installed or removed.
    After this operation, 527MB disk space will be freed.
    Do you want to continue [Y/n]? n
    Abort.


    how do i un-fudge myself now?
     
  2. DerrickH

    DerrickH Basic Pleskian

    17
    85%
    Joined:
    Sep 26, 2010
    Messages:
    33
    Likes Received:
    0
    this is what i got when i tried to install:

    Installing package(s) with command apt-get -y --force-yes -f install postfix ..

    dpkg: dependency problems prevent configuration of postfix:
    postfix depends on libdb5.1; however:
    Package libdb5.1 is not installed.
    postfix depends on libssl1.0.0 (>= 1.0.0); however:
    Package libssl1.0.0 is not installed.
    dpkg: error processing postfix (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    postfix
    Reading package lists...
    Building dependency tree...
    Reading state information...
    postfix is already the newest version.
    postfix set to manually installed.
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    postfix: Depends: libdb5.1 but it is not installable
    Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
    postfix-pcre: Depends: postfix (= 2.7.0-1) but 2.8.3-1 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
     
  3. DerrickH

    DerrickH Basic Pleskian

    17
    85%
    Joined:
    Sep 26, 2010
    Messages:
    33
    Likes Received:
    0
    it actually appears that postfix is no longer installed, i no longer see it in the package list. but it wont install either. what do i do now?
     
  4. DerrickH

    DerrickH Basic Pleskian

    17
    85%
    Joined:
    Sep 26, 2010
    Messages:
    33
    Likes Received:
    0
    tried to see what aptitude could do for downgrading:

    derrick@cableweb3:~$ sudo aptitude install 2.7.0-1ubuntu0.2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    Couldn't find any package whose name or description matched "2.7.0-1ubuntu0.2"
    Couldn't find any package whose name or description matched "2.7.0-1ubuntu0.2"
    The following packages are BROKEN:
    postfix postfix-pcre
    The following packages will be REMOVED:
    php5{u} wwwconfig-common{u}
    0 packages upgraded, 0 newly installed, 2 to remove and 77 not upgraded.
    Need to get 0B of archives. After unpacking 242kB will be freed.
    The following packages have unmet dependencies:
    postfix: Depends: libdb5.1 which is a virtual package.
    Depends: libssl1.0.0 (>= 1.0.0) which is a virtual package.
    postfix-pcre: Depends: postfix (= 2.7.0-1) but 2.8.3-1 is installed.
    The following actions will resolve these dependencies:

    Downgrade the following packages:
    postfix [2.8.3-1 (now) -> 2.7.0-1 (lucid)]

    Score is 22

    Accept this solution? [Y/n/q/?] y
    The following packages will be DOWNGRADED:
    postfix
    The following packages will be REMOVED:
    php5{u} wwwconfig-common{u}
    0 packages upgraded, 0 newly installed, 1 downgraded, 2 to remove and 77 not upgraded.
    Need to get 1,403kB of archives. After unpacking 492kB will be freed.
    Do you want to continue? [Y/n/?] n


    I really should not uninstall php5, my customers would have broken sites then too.

    any suggestions?
     
  5. fearz

    fearz Regular Pleskian

    25
    57%
    Joined:
    Feb 29, 2008
    Messages:
    170
    Likes Received:
    0
    Question

    Was this the update provided by Parallels? or its on your own?

    Because I just found that there is an update that includes Postfix updates...
     
  6. DerrickH

    DerrickH Basic Pleskian

    17
    85%
    Joined:
    Sep 26, 2010
    Messages:
    33
    Likes Received:
    0
    On my own. We ended up doing that aptitude suggested and reinstalled php5 after. working now.

    so dont upgrade postfix to 2.8, **** breaks.
     
Loading...