1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Installing Plesk 10.x on RHEL 6.1 - failed php-imap dependency

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by AdamSwann, Nov 15, 2011.

  1. AdamSwann

    AdamSwann Guest

    0
     
    I am in the process of deploying my 4th Plesk server -- I have three older versions out in production.

    On a virgin RHEL 6.1 server (I've tried both a "minimal" install and leaving everything at the default) the install fails with:

    Exception: Failed to solve dependencies:
    php-imap-5.3.3-3.el6.x86_64 requires php-common = 5.3.3-3.el6
    php-mbstring-5.3.3-3.el6.x86_64 requires php-common = 5.3.3-3.el6

    After the first install failed, I installed 6.1 on a new VM and had the same problem.

    Here are some things I've tried:

    - Installing php, httpd, php-common, etc. prior to firing off the Plesk auto installer.
    - Not having php, httpd, php-common, etc. install.
    - Both running RHN prior to install (to get everything to latest) and not running RHN and sticking with the versions off the install media.

    Any help would be greatly appreciated.

    Adam
     
  2. AdamSwann

    AdamSwann Guest

    0
     
    Problem fixed.

    I managed to resolve this on my own.

    php-imap is part of the "RHEL Server Optional" channel on RHN. This particular machine wasn't subscribed to that channel, so it wasn't able to find the packages to install.
     
Loading...