Question Internal Server Error

Discussion in 'SiteBuilder' started by campertyler, Mar 22, 2017.

  1. campertyler

    campertyler New Pleskian

    0
    20%
    Joined:
    Mar 22, 2017
    Messages:
    1
    Likes Received:
    0
    Location:
    viet nam
    We have one site that gives an error when we try to Publish it.
    Publishing with all other sites works fine but since this is the biggest site with a lot of pictures it seems it takes longer and we get a timeout. (500 Internal Server Error)

    It's always after about 30 seconds so it seems a time-out setting.

    The /var/log/httpd/sitebuilder_error.log gives me:
    Premature end of script headers: php5, referer: http://sitebuilderdomain/Admin/Site/Form

    Error looks like described in http://kb.odin.com/en/5373
    In order to fix the issue I modified the "Timeout" value till 600, but the issue didn't fix.

    Are there some other timeout settings for the SiteBuilder that I can modify ?
    Tyler !
     
  2. UFHH01

    UFHH01 Platinum Pleskian Plesk Guru

    40
    64%
    Joined:
    Jun 11, 2013
    Messages:
    4,909
    Likes Received:
    1,015
    Location:
    Hamburg / Germany
    Hi campertyler,

    unfortunately, you don't provide YOUR operating system, neither do you tell us, which Plesk version ( incl. #MU ) and finally, WHICH PHP - handler you are using.

    According to the mentioned KB - article ( which describes only the php.ini - location "/opt/php52/etc/php.ini" ), did you try to change YOUR corresponding "php.ini" as suggested in the KB - article?


    Possible commands, to find the current setting "max_execution_time" in your php.ini 's on your server:
    Code:
    find /etc/php -type f -name "php.ini" -exec grep --color -Hni "max_execution_time"  {} \;
    find /etc/php5 -type f -name "php.ini" -exec grep --color -Hni "max_execution_time"  {} \;
    find /opt/plesk/php -type f -name "php.ini" -exec grep --color -Hni "max_execution_time"  {} \;
    
    find /var/www/vhosts -type f -name "php.ini" -exec grep --color -Hni "max_execution_time"  {} \;
    Possible commands, to find the "Timeout" - setting in your apache - configuration files:
    Code:
    For Ubuntu/Debian:
    find /etc/apache2 -type f -name "*.conf" -exec grep --color -Hni "Timeout"  {} \;
    
    For CentOS/RHEL:
    find /etc/httpd -type f -name "*.conf" -exec grep --color -Hni "Timeout"  {} \;
     
Loading...