1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ioncube problems! - dont post other stuff plz

Discussion in 'Legacy Sitebuilder Software' started by nullsystems, Oct 23, 2006.

  1. nullsystems

    nullsystems Guest

    0
     
    Hi, I have had extensive use of Sitebuilder with previous versions and found now problems in publishing until 3.0

    Server: FC4 linux
    PHP5, everything up2date.

    Apart from IonCube!

    The ioncube install shipped with SB3.0 is 3.0?
    Yet it needs 3.1 to work. Otherwise it tells me Ioncube isnt installed ( obivously is since you cant run sb without it )....
    And it just fills my logs with " ioncube version < 3.1 etc etc "

    I copied their check.php file ( /usr/local/sitebuilder/htdocs/check.php ), this tells me:
    "
    check.php cannot be decoded by this version of the ionCube Loader. If you are the administrator of this site then please install the latest version of the ionCube Loader."

    However!

    phpinfo tells me:

    "This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.0.4-dev, Copyright (c) 1998-2004 Zend Technologies
    with the ionCube PHP Loader v3.1.4, Copyright (c) 2002-2006, by ionCube Ltd."


    Sooo... apparantly I have it according to php...according to SWSOFT latest... I dont!

    Reasons:
    1. Sitebuilder works, shows up, you can make sites
    2. phpinfo tells me I have 3.1.4 ioncube.
    3. I installed directly from swsoft rpm for sitebuilder
    4. I have all other requirements runnin plesk and everything is full up2date

    Errors:
    1. check.php tells me its wrong version
    2. sitebuilder PUBLISHING tells me its wrong version and wont let me FTP to same server ( or any other ).
    3. swsoft support team tell me this is " impossible " ?!?
    4. I cannot uninstall ioncube rpm, since sitebuilder NEEDS it. I cannot install without it, since sitebuilder NEEDS it.

    What on earth do I do ?!

    :mad:
     
  2. SibProgrammer

    SibProgrammer Regular Pleskian Staff Member

    29
     
    Joined:
    Nov 21, 2004
    Messages:
    342
    Likes Received:
    15
    Don't use
    /usr/local/sitebuilder/htdocs/check.php for checking publishing site.

    Use /usr/local/sitebuilder/resources/publish/check.php instead.
     
  3. nullsystems

    nullsystems Guest

    0
     
    hmm I was told by swsoft to try that.

    However, if they both still try to use ioncube, im quite sure they will both still refuse.

    Im baffled, im awaiting swsoft to look at the server and login but nothing yet.

    Excellent customer service as always....
     
  4. SibProgrammer

    SibProgrammer Regular Pleskian Staff Member

    29
     
    Joined:
    Nov 21, 2004
    Messages:
    342
    Likes Received:
    15
    Yes, You'r right. Both of them are encoded by ioncube. But one of them with ioncube for PHP5 ( /usr/local/sitebuilder/htdocs/check.php), and another with ioncube for PHP4 (/usr/local/sitebuilder/resources/publish/check.php).
    File encoded for PHP5 of course doesn't work on PHP4 with ioncube loader for PHP4.

    So, try to use /usr/local/sitebuilder/resources/publish/check.php
     
  5. nullsystems

    nullsystems Guest

    0
     
    I have tried both, the problem is deffinatly with sitebuilder + ioncube. I have no idea why. Its a fresh install on a brand new server with all requirements using the OS we have used previously.
    The files came directly from swsoft.

    This makes no sense.
     
Loading...