1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Joomla Pre-Installation Errors

Discussion in 'Plesk for Linux - 8.x and Older' started by kharkovyy, Feb 14, 2007.

  1. kharkovyy

    kharkovyy Guest

    0
     
    Hello,

    I have been searching for a solution for this in quite a few different places.

    I'm using Plesk 8.1 on 1and1 virtual server. I'm trying to install Joomla and it keeps giving me pre-installation errors...

    I've been editing php.ini file to get rid of some of those errors and it seems as though i did for the most part. But one thing i'm still having an issue with is the fact that Joomla says "Session save path Unwritable"

    I've changed the path from
    session.save_path = /var/lib/php/session

    to
    session.save_path = /tmp

    and all the permissions are at 777.

    I restarted the server several times and it's not helping.

    Anyone has any suggestions as to how to get Joomla installed on Plesk 8.1?
    Thank you.


    O yeah .. as a separate issue but still concerning with Joomla... i have not been able to successfully turn off Safe Mode. I did change it to Off in php.ini but it's still saying its ON in Joomla
     
  2. pshelter

    pshelter Guest

    0
     
    Session Save Path unwriteable

    Hi, I'm having a similar problem on a Plesk 8.0 installation and joomla 1.0.12. There are some suggestions in this thread that might help if you haven't seen them already.

    Session Save Path thread from 2006

    It hasn't resolved my problems but some people had some luck with it.

    My problem is that it still says "session save path unwriteable" during pre-installation.

    Steps taken:

    /etc/php.ini
    - safe mode OFF
    - * session.save_path /var/lib/php/session
    - ** also tried /tmp as path with no luck

    * chmod /php/session to 777
    ** chmod /tmp to 777

    restarted Apache after saving changes
    /etc/init.d/httpd restart

    In Plesk 8.0
    php safe mode OFF for domain with joomla

    Does anyone else have any suggestions? I'm not a linux guru by any means but am learning quickly. All other directories and files are writeable after some chmod changes but this one just won't cooperate.

    Thanks in advance!
     
  3. pshelter

    pshelter Guest

    0
     
    Turn PHP Safe mode off in Plesk

    Forgot to add this, you need to turn safe mode off in plesk too.

    Go to domains, hosting setup and uncheck PHP safe mode on. Then save and restart the server.
     
Loading...