1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

localhost.localdomain cannot access control panel

Discussion in 'Plesk for Linux - 8.x and Older' started by heavysystems, Nov 16, 2005.

  1. heavysystems

    heavysystems Guest

    0
     
    hi,

    i'm evaluating Plesk on Debian 3.1. Did a fresh install of Debian, did not install any software other than the base OS. Downloaded the Plesk autoinstaller for Debian and allowed it to do its thing.

    It finished and I can access the default homepage for my domains and such, but when I try to go to the control panel on port 8443, it immediately tries to connect to "localhost.localdomain" and the connection is refused.

    I've edited /etc/hosts and all of the config files in /etc/apache2 looking for this localhost.localdomain entry but I can't find it anywhere...

    Can someone please help me with this?
     
  2. ShadowMan@

    ShadowMan@ Guest

    0
     
    General things (never used Debian):

    1. Have you tried access the Plesk interface by browsing to the IP instead of using the domain name?

    2. I always make sure the /etc/hosts has the following (as a minimum): (assuming my server is www.example.com)
    Code:
    # cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1            localhost.localdomain  localhost www [url]www.example.com[/url]
    my.ip.add.ress       [url]www.example.com[/url]
     
  3. heavysystems

    heavysystems Guest

    0
     
    Yes, I edited my /etc/hosts file to include my primary domain. I also edited every apache config file that the default/generic information in it.

    Plesk is doing the right thing when I simply visit a domain that I'm hosting. I get the default page, which is fine. The problem is when I try to access the control panel on 8443. If it was a general DNS resolving issue it would also not resolve correctly when I visit a normal domain. But it is.

    I know this has to be in a Plesk config file somewhere that I can't find. But what surprises me is that I searched and searched and searched the Forums and the Knowledgebase and there is not a single mention of this problem. I find it very hard to believe I'm the first person this has happened to.

    Anyway, where are the Plesk configuration files located? I checked /etc and there's nothing there for plesk...

    Another thing that is frustrating me about this is I installed Plesk on a test server and it worked surprisingly well. So I built a new production server and installed Plesk on it which is failing with this stupid error.
     
  4. heavysystems

    heavysystems Guest

    0
     
    You know, the only thing different that I'm aware of between the test server I installed Plesk on and the new production server is this: the test server was already a working Debian test box that I had installed VHCS on in the past. The new production server was a brand-spanking new fresh ftp install of Debian with no other software installed other than the base OS.

    When installing Debian to use as a Plesk server, when it gets to the point where you tell the install program which servers to install, should I go ahead and choose all of the server packages?? I saw that the Plesk autoinstaller does all of that for me anyway.

    This error is frustrating me. I'm going to try a different OS tonight if I can't get this resolved... :(
     
Loading...