1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Login Troubles

Discussion in 'Plesk for Linux - 8.x and Older' started by jdodge, Jan 4, 2005.

  1. jdodge

    jdodge Guest

    0
     
    Hello, when I try to login I get the following in a Javascript poupwindow...

    Unable to exec utility packagemng: packagemng: Unable to open rpm db: cannot open packages index using db3 - (30978). System error 2: No Such file or directory.

    What could be the matter here? It happened right after I tried to upgrade.
     
  2. spaceout

    spaceout Basic Pleskian

    25
    73%
    Joined:
    Mar 2, 2004
    Messages:
    59
    Likes Received:
    0
    Same problem

    I'm getting the same error. However, it's not after an upgrade. It just started happening out of the blue??
     
  3. awlane

    awlane Guest

    0
     
    Let me guess....

    when you do
    you get: rpm-4.2.3-13 , right ?
     
  4. jdodge

    jdodge Guest

    0
     
    this worked for me

    cd /var/lib/rpm
    rm -f /var/lib/rpm/__db*
    rpm --rebuilddb
     
  5. orion_it

    orion_it Guest

    0
     
    That worked for me as well. Thank you VERY much. I would have panicked if not for this advice.

    Joel Clermont
     
  6. nacarls

    nacarls Guest

    0
     
    Unable to exec utility packagemng: packagemng: empty error message from utility.

    I tried the rpmdb update and still no luck.

    rpm -q rpm - returns

    rpm-4.2.1-4.2

    anyone else having this problem?
     
  7. awlane

    awlane Guest

    0
     
    Did you do rm -f /var/lib/rpm/__db*

    before you did

    rpm --rebuilddb
     
  8. nacarls

    nacarls Guest

    0
     
    Here is a print out from the plesk page:


    Code:
    ERROR  
    
    Unable to create ComponentsChecker object: Unable to exec utility packagemng: Empty error message from utility.
    
    --------------------------------------------------------------------------------
    
    0: /usr/local/psa/admin/plib/class.ComponentsChecker.php:2 psaerror()
    1: /usr/local/psa/admin/plib/common_func.php3:10 componentscheckermaker()
    2: /usr/local/psa/admin/plib/common_func.php3:10 add_optional_locales()
    3: /usr/local/psa/admin/plib/countries.php3:2 lmsg()
    4: /usr/local/psa/admin/plib/common_func.php3:10 locale_list()
    5: /usr/local/psa/admin/htdocs/login_up.php3:2 locale_exists()
    6: /usr/local/psa/admin/htdocs/login_up.php3:2 createsessionadmin()
    7: /usr/local/psa/admin/htdocs/login_up.php3:2 createsession()
    
    
    Havnt touched php nor apache. Both are stock 7.5.1

    Also I noticed, by removing the address page and going back directly to the port accepts you as logged in and allows you to see the control panel again, however I am unable to browse the updater page int he server section.
     
  9. nacarls

    nacarls Guest

    0
     
    yes I did the remove command first :)
     
Loading...