1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Long apache restart time after upgrading to plesk 10.4.4

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by pichlo, Feb 23, 2012.

  1. pichlo

    pichlo Guest

    0
     
    Hey Guys,

    after upgrading to Plesk 10.4.4 (and many other problems) there's still one big problem left. Everytime when I change settings regarding the apache configuration in plesk, apache is offline for several seconds. I've checked the apache error log /var/log/apache2/error.log while creating a new subdomain. Here's the result:

    So apache or what else needs 37 seconds (!) to restart. So I ask myself what the system does in this time. So I take the time reconfiguring the same domain by httpdmng:

    Maybe this are only two equal but indepedant numbers. But the other option is, that plesk stops apache before reconfiguring the domain. This would explain the systems behavour...... In this case Parallels have switch the order of these operations....

    Could everyone confirm this behavour for others plesk installations?
    Does anyone know the order of plesks internal operations?
    Have Parallels changed these order for Plesk 10.4.4?
    Does anyone know how I could reduce these time period?

    Regards
    Martin
     
    Last edited by a moderator: Feb 23, 2012
  2. pichlo

    pichlo Guest

    0
     
    No Answer?

    Hey Guys - especially from parallels,

    no ideas, no answer?

    Martin
     
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,539
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    Try to enable Apache graceful restart instead of typical one as per KB article http://kb.parallels.com/en/112020
    Check also Apache restart interval in Plesk Control Panel GUI: Tools and settings -> Server settings -> Apache restart interval
     
  4. pichlo

    pichlo Guest

    0
     
    This seems to work. Thank you.
     
Loading...