1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

long connection wait in ftp

Discussion in 'Plesk for Linux - 8.x and Older' started by swebs, Aug 4, 2005.

  1. swebs

    swebs Guest

    0
     
    When FTPing into my box (redhat fc2) there is a long pause at the connecting data channel.

    Running Plesk 7.5.2 and after seaching the forums here I did the follow but still no fix.

    1. Made sure
    UseReverseDNS off
    IdentLookups off
    were in my proftpd.conf

    2. made sure -Rt0 was in my
    /etc/xinetd.d/smtp_psa

    3. restarted xintd
    service xinetd restart

    still the same slowness.

    Any help or suggestions would be great.

    Thanks in advance.
     
  2. swebs

    swebs Guest

    0
     
    No one has any suggestions??

    I even tried configuring proftpd in standalone instead of through xinetd but its still the same long wait.
     
  3. poke

    poke Guest

    0
     
    can I see your /etc/xinetd.d/smtp_psa ......
     
  4. swebs

    swebs Guest

    0
     
    service smtp
    {
    socket_type = stream
    protocol = tcp
    wait = no
    disable = no
    user = root
    instances = UNLIMITED
    server = /var/qmail/bin/tcp-env
    server_args = -Rt0 /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    }
     
  5. poke

    poke Guest

    0
     
    your smtp_psa file looks just fine ...... hmmm that's what did the trick for me....

    Also remember to do the same for smtps_psa .......

    Anyone out there have any ideas?? I'm stumped :(
     
  6. poke

    poke Guest

    0
     
    Try updating to 7.5.3, but I doubt that will fix the problem. It is now safe to upgrade to 7.5.3, not the 7.5.4 beta :)
     
  7. swebs

    swebs Guest

    0
     
    I tried that but I get an error during the upgrade.

    error: Failed dependencies:
    psa-api-common = 7.5.2 is needed by (installed) psa-api-rpc-7.5.2-rh9.build75050128.10
     
  8. poke

    poke Guest

    0
     
    How are you upgrading? RPM? or autoinstaller? Is this a VPS?
     
  9. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I posted this in an earlier thread today:

    Is your firewall limiting any of the ports between 1024-65534 (incoming or outgoing)?

    See the proftpd docs on passive port ranges.

    http://www.proftpd.org/localsite/Userguide/linked/config_ref_PassivePorts.html

    I believe the 'default' is for it to try to allocate ports:

    PassivePorts 49152 65534

    If it cannot allocate, then it has to do additional processing to get kernel allocated ports to use which could be contributing to a delay.
     
  10. swebs

    swebs Guest

    0
     
    Poke,

    I was attempting the autoinstaller, because I am not super familar with the rpm method steps.
     
  11. swebs

    swebs Guest

    0
     
    jamesyeeoc,

    Thanks I think that worked.

    Here is what I did.

    I used the PassivePorts line in my proftpd.conf file and set it to a small range of about 30 starting from 49152
    (since you have to open each port 1 by 1 in plesk firewall.) :(

    Then opened that range in the firewall.

    It seems like it is responding better now. I'll see if the customers stop complaining and then I'll know for sure.
     
Loading...