• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Question Magento Softaculous installation has 500 error

I'm wonder why do we get the "main.CRITICAL: Can't create directory" since we have set the directory and files to 777.

Also Have to set the document room to httpdocs/pub ? (This is unrelated to the File Permission issue).
 

Attachments

  • Firefox_Screenshot_2024-01-27T00-02-41.575Z.png
    Firefox_Screenshot_2024-01-27T00-02-41.575Z.png
    14.4 KB · Views: 6
I'm wonder why do we get the "main.CRITICAL: Can't create directory" since we have set the directory and files to 777.

Also Have to set the document room to httpdocs/pub ? (This is unrelated to the File Permission issue).
once I changed it to httpdocs then the plesk default doman page appears and all other pages are 404
 
Ok. The Plesk Default Page might be a different issue.

Would you be able to run,

#plesk repair web yourdomainname.tld as root?

Magento 2 Document Root should be httpdocs/pub. Sorry, It seems I wont be able to help you without actually looking into this server/M2 installation.
 
plesk repair web commerce.meeovicms.com

Checking web server configuration

Repair web server configuration for domains commerce.example.com? [Y/n]
Repairing web server configuration for the domain
commerce.example.com .......................................... [OK]

Error messages: 0; Warnings: 0; Errors resolved: 0
 
Ok. The Plesk Default Page might be a different issue.

Would you be able to run,

#plesk repair web yourdomainname.tld as root?

Magento 2 Document Root should be httpdocs/pub. Sorry, It seems I wont be able to help you without actually looking into this server/M2 installation.
no problem thanks for trying to assist, I just may have to try an alternate install or entirely different platform. Hopefully softaculous can help resolve this as I reached out to them as well, just waiting on a response. Will post here if I find anything for anyone in the future looking at solutions to this problem.
 
Back
Top