• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

mcelog cron error

Pallieter Koopmans

New Pleskian
For future reference (since I had not found this documented somewhere).

>/etc/cron.hourly/mcelog.cron:
>
>mcelog: Cannot access bus threshold trigger `bus-error-trigger': Permission denied

The solution (thanks Tristan for the idea) was to fix the SElinux rights to the triggers file. Here the longer explanation:

>Aug 23 13:01:01 copyhosting run-parts(/etc/cron.hourly)[3171]: starting mcelog.cron
>Aug 23 13:01:01 copyhosting run-parts(/etc/cron.hourly)[3205]: finished mcelog.cron
>
>$ mcelog --client
>
>mcelog: client connect: No such file or directory
>mcelog: client command write: Transport endpoint is not connected
>mcelog: client read: Invalid argument
>mcelog: client connect: No such file or directory
>mcelog: client command write: Transport endpoint is not connected
>mcelog: client read: Invalid argument
>
>/var/mcelog:
>
>mcelog: Cannot access bus threshold trigger `bus-error-trigger': Permission denied
>
>$ uname -a
>
>Linux 2.6.32-573.3.1.el6.x86_64 #1 SMP Thu Aug 13 22:55:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
>
>$ pwd; ll
>/etc/mcelog
>drwxr-xr-x. 2 root root 4.0K Aug 20 23:11 .
>drwxr-xr-x. 123 root root 12K Aug 23 12:55 ..
>-rwxr-xr-x. 1 root root 801 Jul 23 22:35 bus-error-trigger
>-rwxr-xr-x. 1 root root 1.1K Jul 23 22:35 cache-error-trigger
>-rwxr-xr-x. 1 root root 1.2K Jul 23 22:35 dimm-error-trigger
>-rwxr-xr-x. 1 root root 742 Jul 23 22:35 iomca-error-trigger
>-rw-r--r--. 1 root root 6.2K Jul 23 22:35 mcelog.conf
>-rwxr-xr-x. 1 root root 1.3K Jul 23 22:35 page-error-trigger
>-rwxr-xr-x. 1 root root 1.1K Jul 23 22:35 socket-memory-error-trigger
>-rwxr-xr-x. 1 root root 946 Jul 23 22:35 unknown-error-trigger
>
>$ cat /ect/mcelog.conf (partial snip):
>
>bus-uc-threshold-trigger = bus-error-trigger
>directory = /etc/mcelog
>
>$ dmesg | grep mce
>
>mce: CPU supports 10 MCE banks
>
>Plesk 12.0.18 CentOS 6 1200150615.10
>
>$ cd /etc/mcelog/
>
>$ ll -Z
>drwxr-xr-x. root root system_u:eek:bject_r:etc_t:s0 .
>drwxr-xr-x. root root system_u:eek:bject_r:etc_t:s0 ..
>-rwxr-xr-x. root root system_u:eek:bject_r:etc_t:s0 bus-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:bin_t:s0 cache-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:etc_t:s0 dimm-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:etc_t:s0 iomca-error-trigger
>-rw-r--r--. root root system_u:eek:bject_r:etc_t:s0 mcelog.conf
>-rwxr-xr-x. root root system_u:eek:bject_r:etc_t:s0 page-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:etc_t:s0 socket-memory-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:etc_t:s0 unknown-error-trigger
>
>$ chcon --reference=cache-error-trigger *-error-trigger
>
>$ ls -Z
>-rwxr-xr-x. root root system_u:eek:bject_r:bin_t:s0 bus-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:bin_t:s0 cache-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:bin_t:s0 dimm-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:bin_t:s0 iomca-error-trigger
>-rw-r--r--. root root system_u:eek:bject_r:etc_t:s0 mcelog.conf
>-rwxr-xr-x. root root system_u:eek:bject_r:bin_t:s0 page-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:bin_t:s0 socket-memory-error-trigger
>-rwxr-xr-x. root root system_u:eek:bject_r:bin_t:s0 unknown-error-trigger
>
>$ tail /var/log/mcelog
>mcelog: Cannot access bus threshold trigger `bus-error-trigger': Permission denied
>
>$ sh /etc/cron.hourly/mcelog.cron
>
>$ tail /var/log/mcelog
>mcelog: Cannot access bus threshold trigger `bus-error-trigger': Permission denied
>
>No new record, so this solved the problem. No more cron job error emails. PS: I did not have semanage installed, hence the chcon reference.
 
Sorry, could you please explain how this issue related to Plesk?
 
Back
Top