1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Migrating Plesk 8.3 -> 10.4

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Solosoft64, Apr 4, 2012.

  1. Solosoft64

    Solosoft64 Guest

    0
     
    Hello,

    I am having an issue migrating my Plesk 8.3 Installation on FreeBSD 6.2 -> Plesk 10.4 on CentOS 6
    I ran the cli to backup plesk with the -all flag to ensure it downloads all the data off the server. After many hours I
    came upto one large 104gb file. This file is on 8.x format so using the pre9-conversion utility it converted (which took
    a very long time) to 10.x then ran the line given by the pre9 bin to convert upto 10.x.
    Since I am having issues with the restore ill go through the methods I tried and the answers/solutions I have gotten.
    I tried restoring this a few different ways to change variables to ensure its not something on my end causing the
    issues.


    1. Went through the GUI to do the restore. When I imported the file from my scratch disk off the old FreeBSD server I
    copied the data to /root converted it using the tools mentioned above and put it in /var/lib/psa/dump folder so the
    migration utility on the GUI on the 10.4 box would see it. This worked great. I got the utility to perform one step @ a
    time to help troubleshoot where the issues are. I had no problems getting the "Customers" to restore. 100% of them
    restored properly with the correct passwords and permissions the issue is the websites will not restore.

    2. Since a "Giant" restore was not working. I figured something at a more site by site
    level might be the trick.

    /usr/local/psa/bin/pleskrestore --restore /root/plesklatest.converted/converted_info_1204031125.xml -level domains -filter list:website.com -verbose -map /root/pleskmap

    I of course generated the map /usr/local/psa/bin/pleskrestore --create-map pleskbackup.date -map pleskmap first then
    tried to run the command.
    Here is the error I got @ the domain level:

    I did change the website to "website.com" for privacy reasons but the general idea is there. This happens on ANY domain I try to restore. If I choose to restore them all I simply get a giant log with ALL the websites spitting out this same error.

    I don't know where to go from here, ive tried using the migration manager, ive tried 2x different operating systems to
    ensure its not a variable on my end. Debian 6.0 stable and CentOS 6 both fail to restore the domains.

    Im wondering if there is something that I am missing here to possibly push me forward. As I kept trying there is a few
    little changes I picked up googling around these forums here. I changed the /tmp folder outside of /tmp (in psa.conf) just incase there is any issues with size as that partition is a little smaller then my root partition.

    Since there was no errors on the plesk 8.3 machine im starting to think its an issue with the import process and not so
    much the export process, what do you guys think ?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
  3. Solosoft64

    Solosoft64 Guest

    0
     
    Thanks, I will look into those solutions
     
  4. Pomero

    Pomero Guest

    0
     
    Same problem

    I have the same problem, did you managed how to solve this issue?
     
  5. ClaudiaC

    ClaudiaC Guest

    0
     
    Me too !

    I have some domains on two machines with 8.3.0 and regular daily backups of every domain.
    Now I have a new machine with panel 10.4.4
    I have tried to do a restore.
    The new server takes the old backup, do a some type of conversion and then begin to restore the domain.
    It asks me if I want a restore oh the site, the db or the email. I select all, it starts work and end with the message that the restore is completed but it is not true.
    It has restored nothing.
    Can you help me ?
     
Loading...