1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

MU#7 Fails to install

Discussion in 'Plesk 11.x for Linux' started by mschultz, Jul 30, 2012.

  1. mschultz

    mschultz New Pleskian

    10
     
    Joined:
    Jun 25, 2012
    Messages:
    4
    Likes Received:
    0
    No matter how I try to apply MU#7(via the panel, or autoinstaller), it fails. Below is the output from autoinstaller.


    Changing shell for popuser.
    Shell not changed.
    Changing shell for mhandlers-user.
    Shell not changed.
    ===> Preparing upgrade
    Stopping psa... done
    psa is stopped
    Stopping psa... done
    ===> Cumulative database upgrade has been started
    ===> Upgrade completed.
    Loaded plugins: priorities, product-id, rhnplugin
    Repository PSA_11_0_9-dist is listed more than once in the configuration
    Repository PSA_11_0_9-thirdparty is listed more than once in the configuration
    Repository SITEBUILDER_11_0_10-dist is listed more than once in the configuration
    Repository SITEBUILDER_11_0_10-thirdparty is listed more than once in the configuration
    Repository PPB_11_0_9-dist is listed more than once in the configuration
    Repository PPB_11_0_9-thirdparty is listed more than once in the configuration
    Repository rhel-source is listed more than once in the configuration
    Repository rhel-source-beta is listed more than once in the configuration
    WARNING: Yum repository 'base' is absent or not enabled, installation may fail.
    WARNING: Yum repository 'updates' is absent or not enabled, installation may fail.
    307 packages excluded due to repository priority protections
    Package php-5.3.3-3.el6_2.5.x86_64 already installed and latest version
    Running rpm_check_debug
    Installed products updated.
    Exception: Scriptlet or other non-fatal errors occurred during transaction.

    ERROR: Failed to run the Yum utility.
    The Yum utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.


    Here are some of the logs from /tmp/autoinstaller3.log

    Following packages will be installed: php-5.3.3-14.el6_3
    ----------------
    WARNING: Yum repository 'base' is absent or not enabled, installation may fail.
    WARNING: Yum repository 'updates' is absent or not enabled, installation may fail.
    Check package set before installation
    The following packages will be installed because they are required by the packages you selected for installation:
    (regen obsoletes cache) ~empty~emptyChanging shell for popuser.
    Shell not changed.
    Changing shell for mhandlers-user.
    Shell not changed.
    ===> Preparing upgrade
    Stopping psa... done
    psa is stopped
    Stopping psa... done
    ===> Cumulative database upgrade has been started
    ===> Upgrade completed.
    WARNING: Yum repository 'base' is absent or not enabled, installation may fail.
    WARNING: Yum repository 'updates' is absent or not enabled, installation may fail.
    Traceback (most recent call last):
    File "/usr/local/psa/bin/yum_install", line 194, in <module>
    main()
    File "/usr/local/psa/bin/yum_install", line 189, in main
    installer.perform(to_install, opts.remove)
    File "/usr/local/psa/bin/yum_install", line 149, in perform
    raise Exception("Scriptlet or other non-fatal errors occurred during transaction.")
    Exception: Scriptlet or other non-fatal errors occurred during transaction.
    ~emptyExecute command /usr/local/psa/admin/bin/send-error-report install
    FileFetcher: get file (~empty)/PSA_11.0.9/plesk-11.0.9-rhel6-x86_64.inf3
    FileFetcher: get file (~empty)/SITEBUILDER_11.0.10/sitebuilder-11.0.10-rhall-all.inf3
    FileFetcher: get file (~empty)/BILLING_11.0.9/billing-11.0.9-rhall-all.inf3
    FileFetcher: get file (~empty)/NGINX_1.3.0/nginx-1.3.0-rhel6-x86_64.inf3
    Error: Failed to run the Yum utility.
    The Yum utility failed to install the required packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
     
  2. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Looks like you may have to first downgrade php before proceeding ...
     
  3. mschultz

    mschultz New Pleskian

    10
     
    Joined:
    Jun 25, 2012
    Messages:
    4
    Likes Received:
    0
    Seems a bit odd that Plesk installed a higher version of php on install, then now is requiring a lower version.

    Yum shows my current version as:

    php.x86_64 5.3.3-3.el6_2.5 @PSA_11_0_9-thirdparty


    I could be wrong about this, but it seems like my current version is lower than the version its trying to install php-5.3.3-14.el6_3.
     
Loading...