• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Need t upgrade to PHP 5.2 - need advice please

E

edwelly

Guest
Hello all. I own a VDS server at Godaddy and it is running Parallels Plesk Panel v10.0.1_build109101029.17 os_CentOS 5, PHP 5.1.6. I need to upgrade to at least PHP 5.2 but to be 100% I am scared to death. I just got the command line zip working thanks to this htread: http://forum.parallels.com/showpost.php?p=316326&postcount=3

However I am an needing help moving to PHP 5.2. I really do not want to go any higher than 5.2 as I am hosting web sites that are running Wordpress and I am not sure if Wordpress will work with anything higher than 5.2. Since I have over 15 clients on my server I can't afford to take that chance.

Now I will be the first to admit I should not have my own server if I do not know how to do this type of thing, but I was sold this server under the understanding that I would have a support team helping me. That later part turned out not to be true so I am stuck with this.

can anyone help me here? I really need this dumbed down as well. I do not want to take anything for granted.

I appreciate any help you can give me. Thanks! ~ Erik
 
I used the Atomic Rocket Turtle RPM Repository and yum'd it with dependencies.. Ran into a problem of the latest distro being 5.3.x. After searching I found php-5.2.17-1.el5.art and was able to downgrade. I would suggest installing php rpm manually and then exclude it when you run yum, but I'm sure others know better. At least you have more to google.. :p Sorry I could not be more helpful, I did this a while ago and it was the middle of the night...

I needed,

php-xml-5.2.17-1.el5.art
php-cli-5.2.17-1.el5.art
php-pdo-5.2.17-1.el5.art
php-5.2.17-1.el5.art
php-common-5.2.17-1.el5.art
php-gd-5.2.17-1.el5.art
php-mbstring-5.2.17-1.el5.art
php-mysql-5.2.17-1.el5.art
php-imap-5.2.17-1.el5.art

Regards
 
Back
Top