• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Resolved New Let's Encrypt extension upgrade (version 3.1.13) breaks old Plesk versions

RalfMeyer

New Pleskian
Server operating system version
Debian 9
Plesk version and microupdate number
18.0.44.3
Hi everyone,

Today, Plesk released a new version of the Let's Encrypt extension (Change Log for Plesk Obsidian) (version 3.1.13).
It seems that the extension was also updated on older Plesk versions. We still have a few servers running Debian 9 (yeah, I know...) and for this reason old Plesk version (18.0.44.3), which we will upgrade in the coming days / weeks. The Plesk panel on these systems is now not usable, as we get the following error message directly after login into Plesk:
Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.0.2".
I have checked the panel.log and this confirmed that this is related to the Let's Encrypt extension:
[15-Jun-2023 13:05:24 Etc/UTC] PHP Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.0.2". You are running 7.4.28. in /opt/psa/admin/plib/modules/letsencrypt/vendor/composer/platform_check.php on line 24
I think this is due to the fact that these old Plesk panel versions still use PHP 7.4, instead of 8.0.

I think this might be a mistake in the extension update, as as far as I know, Plesk has a way of setting dependencies for new extension versions (as done here, for example: Change Log for Plesk Obsidian)

Is it possible to downgrade the extension? Can you push an update to resolve this for the extension? I totally get that Debian 9 and Plesk 18.0.44.3 is EOL and we are about to upgrade, but obviously this is a problem for us right now and I assume for some other users as well.

Thanks.
 
Hi!

Is it possible to downgrade the extension? Can you push an update to resolve this for the extension? I totally get that Debian 9 and Plesk 18.0.44.3 is EOL and we are about to upgrade, but obviously this is a problem for us right now and I assume for some other users as well.

Thank you for the report, we already are working on the fix.
 
A version with fix is prepared and released.
If you do not have an access to Plesk GUI interface and want to force updating to the new version, use the next command via command line interface,
plesk bin extension --upgrade-url https://ext.plesk.com/packages/16835ed5-f030-4645-a4af-b1afe60e783a-letsencrypt/download?3.1.14-871
 
Last edited:
That command fixed it for us - many thanks.

For reference the old affected server is running:

Product version: Plesk Obsidian 18.0.41.1
OS version: CentOS 8.5.2111 x86_64
Build date: 2022/02/07 23:00
Revision: 8cecdf6536124408249dd8ea2063e3e6f632ba5b
 
Back
Top