1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

New server - how do I authenticate mail senders

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Richard Grevers, Apr 4, 2012.

  1. Richard Grevers

    Richard Grevers New Pleskian

    13
    35%
    Joined:
    Apr 3, 2012
    Messages:
    10
    Likes Received:
    0
    [Resolved] New server - how do I authenticate mail senders

    Plesk 10.4.4 on CentOS 6

    I've just moved all my sites onto a plesk VPS, and they are unable to send emails from contact forms and other web apps. I host all email at Google rather than on my server.

    A typical error is:
    contactdd.mv: Line 91: MvSMTP: Runtime Error: Error sending recipient 'domains@dramatic.co.nz': 5.1.1 : Recipient address rejected: User unknown in virtual mailbox table

    What can I do to tell the server that the from address I'm using is allowed to send mail, since I don't want to create a mailbox for it.
    [update]
    ok - found the disable mail service option for each domain - documentation does not cover this well. It's a pity disabling mail isn't an option on the the service plan templates.
     
    Last edited: Apr 6, 2012
  2. burnleyvic

    burnleyvic Regular Pleskian

    17
    85%
    Joined:
    Nov 9, 2011
    Messages:
    174
    Likes Received:
    1
    Configure the MTA running on the Plesk server to relay from clients connecting from localhost, then configure the apps to connect to localhost, SMTP port 25 to send outbound emails.
     
  3. Richard Grevers

    Richard Grevers New Pleskian

    13
    35%
    Joined:
    Apr 3, 2012
    Messages:
    10
    Likes Received:
    0
    The apps are already using localhost and port 25. My old server OS had a checkbox "use external email" which stopped the system from trying to deliver mail locally.

    The "Configure the MTA" bit is the puzzle - the only controls in the UI allow even further tightening things by disallowing all relaying.
     
  4. burnleyvic

    burnleyvic Regular Pleskian

    17
    85%
    Joined:
    Nov 9, 2011
    Messages:
    174
    Likes Received:
    1
    If I understand correctly you are only hosting websites and not email on your Plesk vps. If this is the case you should disable the email functions in the panel.

    tools and settings -> Mail server settings -> Enable mail management functions in Panel (untick). I *think* this will do what you want but as we use panels mail functions we have not disabled this. Alternatively you can log in as customer click on mail tab -> change settings -> Activate mail service on domain (untick) this will stop plesk from delivering email locally for that domain. This option is more likely to be what you want but it must be done per domain.
     
Loading...