1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

No access to plesk after 10.4.4 update

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by BartGrzy, Dec 17, 2011.

  1. BartGrzy

    BartGrzy Guest

    0
     
    Hi,
    Ive just updated my plesk panel to 10.4.4 version. Since update my panel became unavailable for anyone. Anytime I try to login in it returns following error :

    Server error (code 500): Exception with message 'SP id=yrk5xbd2n5xza5pbfiu75j6c2dc4yglw6gp is not found.' caught at top level.


    Any sugestions how can this be fixed?

    Thanks
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,238
    Location:
    Novosibirsk, Russia
    Did you try bootstrapper repair? (Find in in KB articles.)
     
  3. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Run /usr/share/plesk-billing/integration --command=repair-all and post here the output
     
  4. BartGrzy

    BartGrzy Guest

    0
     
    Sorry for late reply, Ive been away for christmas holidays.
    Here is the output :
    [root@]# /usr/share/plesk-billing/integration --command=repair-all
    Customer & Business Manager has been installed but it requires the additional configuration for the first start.
    Run the integration utility with the install command to complete the configuration.
    [root@]# /usr/share/plesk-billing/integration --command=install
    Repair integration with local panel:
    Try to repair integration...............................
    The '/usr/share/plesk-billing/integration' utility was failed with the unknown message:
    <message>
    Wrong panel administrator's credentials were provided. Correct the credentials on the panel settings page.
    </message>
    All details of the problem has been stored into the '/usr/share/plesk-billing/integration.crash.log' file.

    Output of this command you can see in the '/var/lib/plesk-billing/tmp/integration[2011-12-28 21:12:36].log' file.


    I've also tried bootstrapper repair, all went good but it didnt change anything. Plesk still doesnt work..
     
    Last edited by a moderator: Dec 28, 2011
  5. BartGrzy

    BartGrzy Guest

    0
     
    Found solution! I've disabled sso by using /usr/local/psa/bin/sso --disable command. My panel became accessible now, but what are disadvantages of disabled sso?
     
  6. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Disadvantage of disabled SSO is the following - you won't be able to go to Customer & Business Manager integrated with Plesk Panel transparently, CBM will ask your login and password.

    Do you use Customer & Business Manager?
     
  7. lock2007

    lock2007 Guest

    0
     
    I can't acces to

    I can't access to CBM

    this is the output of /usr/share/plesk-billing/integration --command=repair-all command
    Customer & Business Manager is upgrading to version 10.4.4-1. Please wait.
    Upgrading...............................................[ OK ]
    Update permissions for actions..........................[ OK ]
    Repair integration with local panel:
    Try to repair integration...............................[ FAILED ]


    Failed to run command '/usr/local/psa/admin/bin/billing-integration --command='upgrade' --from-version='7.0.0-1' --to-version='10.4.4-1'' Exit code: 254
    Output:
    Upgrading...............................................[ OK ]
    Update permissions for actions..........................[ OK ]
    Repair integration with local panel:
    Try to repair integration...............................[ FAILED ]


    help please
     
  8. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Hello,

    Please enable debug output (http://kb.parallels.com/en/9300, item 1 only since you can't log in to CBM)
    Then execute the command /usr/local/psa/admin/bin/billing-integration --command='upgrade' --from-version='7.0.0-1' --to-version='10.4.4-1 and post here the output
     
  9. lock2007

    lock2007 Guest

    0
     
    hello,
    I made it and this what I got :

    Failed to run command '/usr/local/psa/admin/bin/billing-integration --command='upgrade' --from-version='7.0.0-1' --to-version='10.4.4-1'' Exit code: 254
    Output:
    Upgrading...............................................[ OK ]
    Update permissions for actions..........................[ OK ]
    Repair integration with local panel:
    Try to repair integration...............................[ FAILED ]

    Wrong panel administrator's credentials were provided. Correct the credentials on the panel settings page.
     
  10. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Please provide credentials to the server (login/password to the panel and login/password for SSH) via private message.
    Or contact Parallels Support Team
     
  11. lock2007

    lock2007 Guest

    0
     
    Done,
    thanks again
     
  12. pc-notdienst

    pc-notdienst Guest

    0
     
    Same Problem

    Hi,

    i have the same problem. I cant finish the update to plesk 10.4.4.

    Installation is in progress, please wait...

    Repair integration with local panel: Try to repair integration...............................The '/usr/share/plesk-billing/integration' utility was failed with the unknown message: Wrong panel administrator's credentials were provided. Correct the credentials on the panel settings page.All details of the problem has been stored into the '/usr/share/plesk-billing/integration.crash.log' file.Output of this command you can see in the '/var/lib/plesk-billing/tmp/integration[2012-01-17 11:44:56].log' file.Installation has been completed with errors.

    i tried the repair but the same message appears.
     
  13. SupportI

    SupportI New Pleskian

    12
    60%
    Joined:
    Mar 6, 2012
    Messages:
    2
    Likes Received:
    0
    Hi,

    I have the same problem : Update 10.4.4 cant finish due to same message when upgrade CBM to 10.4.4-1
    Upgrade is in progress, please wait ....
    And same message when repairing integration
    Have you solved it ?

    Thanks
     
  14. drstomp

    drstomp New Pleskian

    12
    85%
    Joined:
    Feb 8, 2012
    Messages:
    9
    Likes Received:
    0
    Customers unable to access accounts with sso enabled or disabled

    So interesting problem. My provider is Media Temple and a couple of months ago they reset all my users passwords as their was supposedly some sort of breach to some of their software/server. After they did this none of my customers/subscribers can access their control panels. Am am using the billing manager, and it is working. I have gotten pretty familiar navigating my way around the commands to repair etc.

    Currently I have one account I am playing with to see if I can fix.

    First Problem:
    SSO is enabled, my login url is... https://xxx.com:8443/sso/ui
    I enter the credentials from the users account and it quietly refreshes the page with no error.

    I can request password email, and enter the sent pass and still does same thing.

    If I disable SSO I get the error... "This login is associated with a billing account, please use the credentials that were emailed to you ..." yadda yadda

    I have reset this users password in the control panel, and via command line to no avail.

    I just reset my hostname and ran the repair all script with no errors to try and fix this as mentioned in this article.
    http://kb.parallels.com/en/11204

    Additionally, If I go into the billing subscription manager and try to re-sync the subscription I get the error "Error: The following errors occurred while syncing the selected subscriptions:
    Failed to sync subscription #2: not provisioned yet
    Please resolve the problems manually and retry to sync again."

    I have done quite a bit of digging on this issue as well, and cannot figure out what I need to correct to fix the provisioning. I am not sure if these issues are related.

    I am pretty much out of options to try and this has been a lingering problem for weeks now. Can you get back with me and let me know what else I can do?
     
  15. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Hello,

    As far as I understand you can log in to Business Manager as admin.
    Select one test customer and try the reset his password through BM - go to Customers, open his account, click "Edit Contact Info" and type new password.
    Then try to log nas this customer.
     
  16. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Please click one of the Quick Reply icons in the posts above to activate Quick Reply.
     
  17. drstomp

    drstomp New Pleskian

    12
    85%
    Joined:
    Feb 8, 2012
    Messages:
    9
    Likes Received:
    0
    Correct, I am able to log into the hosting control panel, the billing panel, and the SSO is working allowing access to both with the same password.

    OK I was able to change the password with that method.
    The url that the customers billing panel is available after clicking the "login" link is...
    https://XXXXXXXXX.com:8443/plesk-billing/admin/index.php

    When logged in, the user still has no hosting control panel available there. Only the billing panel is active. Is there another setting that is preventing this access? It seems like it was available before this mass password reset.

    To try and access the users hosting control panel I try and go to the same url I access my admin panel via...
    I tried to go to
    https://XXXXXXXXX.com:8443
    which redirects me to the sso...
    https://xxxxxxxxxx.com:8443/sso/ui

    And I try to enter the users same information and it quietly fails.

    Thoughts? Let me know if you need screen shots or anything. Or if I need to PM you anything.
     
    Last edited: Jul 3, 2012
  18. EugeneL

    EugeneL Regular Pleskian

    20
    57%
    Joined:
    Feb 18, 2011
    Messages:
    461
    Likes Received:
    0
    Could you please send me access credentials to your server via private message. I'll take a look on your issue.
     
Loading...