1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

open_basedir problem

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by BojanK, Jan 12, 2011.

  1. BojanK

    BojanK Guest

    0
     
    Hello,

    I'm using Ubuntu server and Plesk 10.0.1 latest version, and since this morning out of the sudden whiteout any changes made to server for past 20 days my php sites are not working. Once I have enabled display errors in php.ini file located at /etc/php5/apache2/php.ini file I sow this error message

    Warning: Unknown: open_basedir restriction in effect. File(/var/www/vhosts/neseco.co/httpdocs/index.php) is not within the allowed path(s): (/var/www/vhosts/neseco.co/httpdocs/:/tmp/) in Unknown on line 0

    Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0

    Fatal error: Unknown: Failed opening required '/var/www/vhosts/neseco.co/httpdocs/index.php' (include_path='.:') in Unknown on line 0

    Now I tried any reasonable solution.

    1. Adding vhost.conf file to each domain and setting open_basedir none option
    2. Modifying php.ini file

    It is strange that every website that I'm hosting is not working, Plesk Panel is the only thing that is working under php.

    Can anyone suggest as I don't know where and what to look for anymore.

    Thank you!
     
  2. marco.saiu

    marco.saiu Basic Pleskian

    23
    90%
    Joined:
    Dec 10, 2008
    Messages:
    50
    Likes Received:
    0
    Try to configure this domain for run PHP in Application CGI... This setting is in Web Site and Domain and click in domain name you can change php runtime...

    I attempt your news! Have a nice day!
     
  3. BojanK

    BojanK Guest

    0
     
    Problem solved!!

    Marco

    Thank you, you have saved me the time and trouble, now everything works PERFECT!!

    Thank you again.
     
  4. fogelf

    fogelf Regular Pleskian

    23
    37%
    Joined:
    Feb 10, 2010
    Messages:
    103
    Likes Received:
    0
  5. EmilioO

    EmilioO New Pleskian

    18
    85%
    Joined:
    Jan 13, 2011
    Messages:
    18
    Likes Received:
    1
    It's a Ubuntu Package BUG!

    yesterday night I update php5-common and libapache2-mod-php5 to 5.2.4-2ubuntu5.13....

    all php were in blank ...

    this is the bug: https://bugs.launchpad.net/ubuntu/+source/php5/+bug/701765


    I manually install 5.2.4-2ubuntu5.12 to fix the server.
    this morning ubuntu has updated the package to .2.4-2ubuntu5.14 solving the problem but 1and1 official repository still have .2.4-2ubuntu5.13 version....
     
  6. lhwparis

    lhwparis Guest

    0
     
    thanks for that, it was realy an ubuntu problem. bug is fixed now.
     
Loading...