1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

osCommerce-use search engine urls problem

Discussion in 'Plesk for Linux - 8.x and Older' started by modom, Jul 26, 2005.

  1. modom

    modom Guest

    0
     
    In the osCommerce store admin under configuration/my store you can set "use search engine urls" to true or false.

    Each time I set this to true and then try to shop I get a blank page saying:

    Not Found
    The requested document was not found on this server.

    Does anyone know how to fix this via the server with plesk so I can use this setting or use any of the seo contributions that need this set to "true"?

    Thanks!
     
  2. hardweb

    hardweb Guest

    0
     
    Definitely it can not be solved from inside Plesk, check if Oscommerce uses for this apache mod_rewrite. If so it can be solved only from command line, but it depends on what it does exactly.
     
  3. modom

    modom Guest

    0
     
    Hi,

    I had to add this to /etc/httpd/conf/httpd.conf file:
    AcceptPathInfo On
    This could have been added to the vhost.conf file or a .htaccess file in the root of the oscommerce store.

    Then you have to have the cookie setting turned on under admin/configuration/sessions

    This removes anything after the ? in the url which is the sid ID.

    Funny thing though on all my stores this works flawlessly except for 2 stores. When the cookie listing is turned on and you try to checkout of the store to buy something you are taken to the cookie_usage.php page in oscommerce which says you don't have cookies enabled. I do have cookies enabled because the same browser doesn't do that on other stores so don't know exactly what is going on there.
     
  4. modom

    modom Guest

    0
     
    I set this in my vhost.conf and vhost_ssl.conf file for the open_base problem still in oscommerce while saving a backup using gzip and zip:

    <Directory /home/httpd/vhosts/designhosting.biz/httpdocs>
    php_admin_value safe_mode 0
    php_admin_flag register_globals on
    php_admin_value open_basedir none
    </Directory>

    If I was to set this in each vhost.conf and vhost_ssl.conf file for each store on my server would there be any security risk whatsoever?

    If there is a security problem how would I fix it so I get no errors when using backup and using gzip and zip?

    Thanks!
     
Loading...